Phantom Advanced Take Off problem and Horizon on Yaw

Joined
Dec 18, 2020
Messages
2
Reaction score
0
Age
77
Hello Friends,
I am new to this forum so here goes. I have a Phantom 4 Advanced. I have two questions that I need help on. When I hit the Take Off button on the app the drone starts up just fine and rises. The problem is that it does not stop rising at 4 feet. It keeps going up without me touching the joystick. The only way to stop it it to control with the left joystick. This happens every time. The Compass and IMU are on normal.
2nd Question: When I turn the drone (Yaw) with the joystick it will tilt and lose the horizon until I stop and then it will slowly regain the correct horizon. All the other times of normal flying the horizon is just fine.
As a newbie any help with this would be appreciated. Called DJI and no help.
 
Joined
Dec 25, 2016
Messages
1,899
Reaction score
1,155
Location
Tucson, Arizona
Does the takeoff issue present itself when you takeoff manually?
Is the camera set to fpv mode? I really can’t remember if that setting is available in the advanced model.
 
  • Like
Reactions: Jim Canada
Joined
Jan 29, 2018
Messages
210
Reaction score
104
Age
65
Check to see if precise take off is check. Precise take off goes up and flys around to gather data. I had this happen to me. Kinda Freak me out. Then I read in Manuel this is normal. As far as your camera it might be in fpv mode as starz said. Hope this helps

safe flying
 
  • Like
Reactions: Jim Canada
Joined
Dec 18, 2020
Messages
2
Reaction score
0
Age
77
Does the takeoff issue present itself when you takeoff manually?
Is the camera set to fpv mode? I really can’t remember if that setting is available in the advanced model.
It happens when I hit the Auto Take-off on the screen not when I take off manually. I am not sure how to change the FPV mode or even if that option is available on my Advanced. Precise position is checked on.
 
Joined
Dec 25, 2016
Messages
1,899
Reaction score
1,155
Location
Tucson, Arizona
not sure how to change the FPV mode
That option is there on the advanced.
From the main controller settings, click on the camera icon, then you will see ”gimbal mode” at the top of the page. To the right you will see a blue outlined box. It will say either “follow” or “fpv”. Most times people use “follow”. If it says “fpv”, touch that and you can change to follow.
 

New Threads

Members online

Forum statistics

Threads
140,509
Messages
1,448,379
Members
102,302
Latest member
Empyreus