phantom 4 sd card problem

Joined
Mar 6, 2019
Messages
78
Reaction score
14
Age
25
something really strange is happening to my phantom 4, when i insert the sd card sometimes fan doesn't work, also i don't get the video feed, i tried 3 different sd cards so i think it probably has to do something with firmware or camera board, has anyone tried replacing the sd card slot ???
 
Joined
Feb 11, 2019
Messages
118
Reaction score
59
Age
68
Location
San Antonio
Try restoring factory defaults and refreshing firmware with Assistant 2 before tearing into the circuitry.

Free and easy. May be all it needs.
 
Joined
Mar 6, 2019
Messages
78
Reaction score
14
Age
25
Try restoring factory defaults and refreshing firmware with Assistant 2 before tearing into the circuitry.

Free and easy. May be all it needs.
not sure if it's going to work for me because i have tried updating, resetting etc.. but still doesn't work, however i agree that you gotta start with simple checks
 

ianzone

5000KM TO SOUTHPOLE
Premium Pilot
Joined
May 22, 2016
Messages
5,591
Reaction score
3,132
Age
50
Location
EARTH.NZ
something really strange is happening to my phantom 4, when i insert the sd card sometimes fan doesn't work, also i don't get the video feed, i tried 3 different sd cards so i think it probably has to do something with firmware or camera board, has anyone tried replacing the sd card slot ???
Does the fan self test when first turn drone on ?what sort of updating you do,,firmware or app ? Did you start with imu calibration ,did you try another usb cord for video feed,you still should have cam view with no sd card but me not think that's the fault,,what colour is your gimble light,nice and green.no red light on remote and nice and green,,drone link light green ?
 
  • Like
Reactions: giorgimonk
Joined
Mar 6, 2019
Messages
78
Reaction score
14
Age
25
Does the fan self test when first turn drone on ?what sort of updating you do,,firmware or app ? Did you start with imu calibration ,did you try another usb cord for video feed,you still should have cam view with no sd card but me not think that's the fault,,what colour is your gimble light,nice and green.no red light on remote and nice and green,,drone link light green ?
Does the fan self test when first turn drone on ?what sort of updating you do,,firmware or app ? Did you start with imu calibration ,did you try another usb cord for video feed,you still should have cam view with no sd card but me not think that's the fault,,what colour is your gimble light,nice and green.no red light on remote and nice and green,,drone link light green ?
something is clearly wrong with the camera board, i had my sd card slot replaced by the local shop and i think they ruined something gotta order new one or take it to authorized shop
 
  • Like
Reactions: ianzone

ianzone

5000KM TO SOUTHPOLE
Premium Pilot
Joined
May 22, 2016
Messages
5,591
Reaction score
3,132
Age
50
Location
EARTH.NZ
something is clearly wrong with the camera board, i had my sd card slot replaced by the local shop and i think they ruined something gotta order new one or take it to authorized shop
Ah ok you could have metion that in first post,yes sound not right after reading that,I had no idea someone already poked and prodded it,,well I hope next one works for you
 
  • Like
Reactions: giorgimonk

ianzone

5000KM TO SOUTHPOLE
Premium Pilot
Joined
May 22, 2016
Messages
5,591
Reaction score
3,132
Age
50
Location
EARTH.NZ
Been thinking and should have said take back to whoever did work and get them to correct it,,have to ask but why was this changed anyway,was it tested
 

New Threads

Forum statistics

Threads
136,090
Messages
1,407,534
Members
99,034
Latest member
farjot