Phantom 1 P330 motors won't start

Joined
Dec 17, 2018
Messages
4
Reaction score
0
Age
57
Hi. I bought a Phantom 1 from a friend and it worked fine for 3 days bit now the motors wont start. I get green light so GPS is ok. When I do the CRC and put both sticks down and in there is no response from the motors. I know the remote is connecting as the green light on the Phantom blinks quickly when I push the sticks down and in. Any suggestions would be greatly appreciated.
 
Joined
Oct 31, 2014
Messages
1,981
Reaction score
343
Age
49
Location
Manchester UK
Hi. I bought a Phantom 1 from a friend and it worked fine for 3 days bit now the motors wont start. I get green light so GPS is ok. When I do the CRC and put both sticks down and in there is no response from the motors. I know the remote is connecting as the green light on the Phantom blinks quickly when I push the sticks down and in. Any suggestions would be greatly appreciated.

Sounds like something has gone bad, i would take the shell top off and check for any loose wires, the remote could also be the issue, google search how to calibrate the transmitter as it may not be seeing the full stick movement
 
Joined
Dec 17, 2018
Messages
4
Reaction score
0
Age
57
Thanks for the reply. I took the shell top off last night and pressed the little button by the LED to bind the remote and it worked. I disconnected and reconnected the battery and it stopped working gain. The remote binds every time and I got it to work randomly one more time but stopped again when I disconneted the battery. Not sure what this means ?
 

New Threads

Forum statistics

Threads
136,431
Messages
1,410,986
Members
99,225
Latest member
68rs