Professional P3P not connecting to Go app

Joined
Sep 13, 2016
Messages
18
Reaction score
8
Location
Woodstock, Ontario, Canada
I'm new here, and new to drones in general. My P3P connects to the wireless controller (green light on controller) and I can use the dial to move the camera up and down. The controller is in "P" mode. I am using a Samsung A5 phone with Android 6.0.1. I'm not sure how to tell what version of the Go app I'm using, but it's the latest version includes Mavic. All batteries are fully charged 100% on controller, phone, and P3P.

The problem is, when I connect the USB cable, the Go app starts automatically, but the "camera" button under P3P is grayed out (not blue) and when I tap it, I just get a black screen with all the controls grayed out.

I've tried seven different USB cables, including the official Dji cable that came with my drone. I've tried plugging and unplugging the cables in a different sequence. I always turn on the controller first, wait a minute or two, then turn on the P3P, wait a minute, and then connect the phone. Once in a while it will work and I'll get the blue "camera" button in the app, but 95% of the time it doesn't connect. Thanks for your help!
 
Joined
Jun 25, 2016
Messages
143
Reaction score
11
Age
24
Have you tried it with a different device? Also, look on the side of your OFDM module (white box on bottom). Do you have a solid green or flashing green/red? It might need to be bound.
 
Joined
May 25, 2015
Messages
1,219
Reaction score
373
Age
80
Location
London UK
Have you registered the drone with DJI, and given it a name, on the GO app?
 
Joined
Sep 13, 2016
Messages
18
Reaction score
8
Location
Woodstock, Ontario, Canada
To answer the questions above...

Have you tried it with a different device?
Yes, I have tried it with another device. It works great with my wife's iPhone 5. No problems at all. Also, for what it's worth, the Samsung works great with my Osmo connected over wi-fi.

Look on the side of your OFDM module (white box on bottom). Do you have a solid green or flashing green/red?
It is s solid green light. I'm sure there is a strong connection between the controller and drone, as I can move the camera up and down using the controller. I'm pretty sure the issue has something to do with my phone, the USB connection, and possibly the controller or the Go app.

Have you registered the drone with DJI, and given it a name, on the GO app?
No, I haven't. I guess I should do that. However, I have been able to fly the P3P a few times, even without registering it. I'll register it and report back in this thread.

I should also mention that when the Go app is running, I swiped down on my phone, and from the USB options, I chose the "transferring media files" option.

Thanks for the help!
 
Joined
Jun 25, 2016
Messages
143
Reaction score
11
Age
24
What firmware are you using? Also, are you running any other apps like Litchi that might be conflicting with go?
 
Joined
Sep 13, 2016
Messages
18
Reaction score
8
Location
Woodstock, Ontario, Canada
What firmware are you using?
I'm not sure. How do I check?
BTW, I see that I'm using Go app version 3.0.1

Also, are you running any other apps like Litchi that might be conflicting with go?
No, I closed every other app on my phone. Only the Go app is running. I don't even have Litchi installed on my phone.

I have turned on "Enable USB Developer Option" in the Go app. Also, I've seen this in other threads so I'll mention it, I'm not using an HDMI upgrade board.
 
Last edited:
Joined
May 25, 2015
Messages
1,219
Reaction score
373
Age
80
Location
London UK
I can't do this, because the app is not communicating with the drone at all. The controller communicates with the drone, but the app doesn't.
Something strange going on here...you say that you've flown the drone a few times, but normally you can't start the motors until you've created an account in the GO app and registered the drone. Did you buy this new, or is it maybe a drone that someone has already registered? I'm afraid I don't have any answers to your problem.
 
Joined
Sep 13, 2016
Messages
18
Reaction score
8
Location
Woodstock, Ontario, Canada
Something strange going on here...you say that you've flown the drone a few times, but normally you can't start the motors until you've created an account in the GO app and registered the drone. Did you buy this new, or is it maybe a drone that someone has already registered? I'm afraid I don't have any answers to your problem.
The drone was bought as an "open box" on eBay, and classified as "new/other" which I think means it was a demo unit or refurbished. It came in it's original box and looks new, but it had been opened, and likely flown before, as only some of the original packaging was present. I'm starting to think it had been registered by someone else at one time.
 
Joined
Jun 25, 2016
Messages
143
Reaction score
11
Age
24
Where are you located? I can possibly lend you a controller to test and see if thats the problem.
 
Joined
Jan 29, 2016
Messages
7
Reaction score
1
Age
66
I had the same problem with my iPhone when it was in a case. Removed the case as a "pass through" connection connected directly to the phone and no more problems.


Sent from my iPad using PhantomPilots
 
Joined
Nov 11, 2014
Messages
52
Reaction score
14
Interesting. I'm not using a case, but thanks for the reply.
I'm just down the road from you in London.

My buddy had the same issues on Friday. He ended up removing and re-installing the app on the device where it wasn't working. That seemed to work for him. Good luck


Sent from my iPad using Tapatalk
 
Joined
Jul 17, 2016
Messages
35
Reaction score
2
Age
39
I had the same problem with my Samsung Galaxy S2 tablet you need to go to developer options under settings and turn that on and then scroll down and go to USB debugging and turn that on and then scroll down to USB configuration and choose the RNDIS (USB Ethernet) option. You don't want to have it on the MTP media transfer protocol. It might take a couple times choosing the RNDIS option because sometimes it goes right back to MTP and if it does that just go back and click on RNDIS again until it connects to your GO App.
 
  • Like
Reactions: Walkers13
Joined
Nov 11, 2014
Messages
52
Reaction score
14
I had the same problem with my Samsung Galaxy S2 tablet you need to go to developer options under settings and turn that on and then scroll down and go to USB debugging and turn that on and then scroll down to USB configuration and choose the RNDIS (USB Ethernet) option. You don't want to have it on the MTP media transfer protocol. It might take a couple times choosing the RNDIS option because sometimes it goes right back to MTP and if it does that just go back and click on RNDIS again until it connects to your GO App.

This actually resolved the issue for my buddy. Removing and re-installing the app was temporary. He thanks you!




Sent from my iPad using Tapatalk
 
  • Like
Reactions: Jree80
Joined
Jul 17, 2016
Messages
35
Reaction score
2
Age
39
This actually resolved the issue for my buddy. Removing and re-installing the app was temporary. He thanks you!




Sent from my iPad using Tapatalk
You're welcome. Tell your friend I'm happy to hear that his issue was resolved for my advice.
 

New Threads

Forum statistics

Threads
136,109
Messages
1,407,675
Members
99,043
Latest member
JbroDrone