No signal on used and brand new P3P Any ideas?

Sep 12, 2015
Reaction score
Fellow fliers,

I'm after a bit of advice, help or any suggestions.

I purchased my first P3P back in August 2015 and had some great flights with it stock, never had flyaways, no issues with cracks (older motor ver), nothing. It's been great and I've loved flying it. I even purchased the DJI Hardshell case, Polor Pro filters and some extra batteries too. It's been with me on all my caravan holidays and I've got some really good video and shots.

I came across Litchi and was happy to sign up as a beta tester and it became my main control app for a while and started using that, alongside the extra channel hack which to be honest was usually left to AUTO.

I updated the controller myself around September 2015 to use the ITElite panel antenna with some great distances achieved during Sept/October when all of a sudden around Bonfire night I started to get loss of signal in the same areas I've been flying around for the past few months.

I thought that the ITElite antenna may have somehow become faulty so I opened up the controller and re-connected the stock antennas that I'd left attached with the wires tucked away, took out the P3P and went for another flight. No further than 300ft in height and distance, the DJI Go app starts telling me loss of signal again (Control and Video). I'm stood literally beside it, antennas in the correct position and it starts to auto land. Luckily I managed to get to it and hand catch.

I thought that I may have buggered the remote with the tinkering using the ITElite panel at some point but rather than go out and spend hundreds on a new controller, I went out and purchased ANOTHER P3P just yesterday (Friday 4th).. I charged up, paired and used the new controller today on the old P3P and I'm still getting the same issues with signal loss using all the same firmware versions and the same Galaxy S6 Egde device so I'm now assuming it's not the controller. I now pair the new controller with the new P3P and again the same thing happens!! Loss of signal at 300ft and 300ft away. I've had the both the older controller and RC on older firmwares and very recently updated to the latest firmware and nothing has made a difference! I've used my iPad Air 2, my cheap Samsung Galaxy Tab and the same thing happens. Loss of signal!

So for summary.

I've used various versions of the DJI Go app for both android and IOS and Litchi for android at different versions and the same thing happens. I'm yet to take it anywhere else to fly it as I don't have the confidence to be able to control it outside of where I do now on the same field in Nuneaton, Warwickshire UK. Both controller and HD video feeds are losing signal...!

I've tried using the custom channel option and tried various channles and the same thing happens. I can be stood right next to the drone hovering and the app is saying weak signal. Play with the antennas, makes no difference.

My Samsung Galaxy S6 Egde can be in normal mode with Bluetooth and WIFI on and even flight mode. Same thing happens. I've used various usb cables, thunderbolt cables. Various SD cards, different settings for video transmission etc. Nothing. I'm literally at the end of my tether!

Can anyone suggest anything?

I understand it could be interference from something nearby and maybe the only way to test it take further afield but at the moment, I'm used to this huge open field, out of the way, not near an airport and not near anyone's property.

Thanks again for your help
I wish I could help but the same thing happened to me. Everything was find on my P3Pro, had it since last July. All if a sudden, I couldn't get a signal. So I tried everything I could think of from relinking aircraft to getting parabolic antenna. Finally it crashed beyond repair. Never found out why. Got a good deal on a Advanced, it's working great. You might consider sending it in for repair , something is not right. Good luck.
Thanks for the reply, Kenjaco2

Both of them though? The other is a day old! Brand new!
I would give it a try in a new area. There might be a new source of interference where you fly, since it is bad with both new and old phantom. It doesn't seem likely that both would go bad with the same fault.
That's what I'm now thinking .....ill see how the weather is tomorrow.
Do you know one thing? Just disconnect antenna and try to fly. You will get connections unto 200-300' depending on the site condition. That shows that you get it working even if you don't have antenna connection for some limited distance.

Does it give you any clue? I believe but may be 100% wrong that you have loose antenna connections on aircraft side. Chances of they getting loose are high because of continuous vibrations. My two cents.
Hi Guys, Thanks for the replies. Sorry for the delay in replying. It's been a few hectic months and I've not had chance to reply sooner!

So. In the end, I managed to return the new P3P and took my older one out to a new location and it seemed to work flawlessly. There must be something near to where I live that's causing huge interferences. I use the multi channel hack but I don't see any problems with the channels in question whilst flying! Anyhow, I've managed to reconnect the ITElite panel and I'll just have to use the drone in a different area.

Thanks again.

Members online

No members online now.

Forum statistics

Latest member