Loosing power

Joined
May 20, 2014
Messages
55
Reaction score
0
Location
Palmdale, California
Hey
I 've been having an issue with loosing power half way thru my flight. Battery power iwere at 60% and the Phantom Vision 2+ just starts dropping and lands. I throttle up and nothing happens. This has happened several times now with different batteries and I can't figure what it could be. Any help would be appreciated.

Rick
 
Hey
I 've been having an issue with loosing power half way thru my flight. Battery power iwere at 60% and the Phantom Vision 2+ just starts dropping and lands. I throttle up and nothing happens. This has happened several times now with different batteries and I can't figure what it could be. Any help would be appreciated.

Rick
Try charging and then hooking up your Vision to the assistant and checking battery voltage and cell voltage. You could have a bad charger, several bad batteries or a cold solder joint on the main power leads.

Jeremy
 
Well I checked all four batteries with the assistant and they all showed as good voltage. I flew again this morning and the same thing happened with all four batteries. I drained them all to 8% and now I'm charging them with the field charger to see if it's the charger. I'll try again tomorrow and if it's still doing it I think I need to open her up and see if there are any connections that are loose. Also does anyone know if I should upgrade the firmware to the current one?? One thing that I noticed is that the battery starts off at 22 minutes and within a couple of minutes it drops to 10 minutes and all I was doing was hovering.

Rick
 
How many cycles on the battery? Are they series 2 batts (part number PH2-5200)?
Does the battery percentage go red when throttling hard, especially against the wind?
 
After charging a;; the batteries with the field charger I was able to have good flights. no issue. I guess I guess I need to replace the charger. Two of my batteries are the older version and two are the new ones. The new ones only have had 5 charges and the old one probably 20 to 25 charges..
 
After charging a;; the batteries with the field charger I was able to have good flights. no issue. I guess I guess I need to replace the charger. Two of my batteries are the older version and two are the new ones. The new ones only have had 5 charges and the old one probably 20 to 25 charges..
Had the same thing happen to me. Mine happened when I rotated the drone to change direction. It happened on 2 different drones. Both were running the 3.08 software, Assistant 3.8. I suspect it has something to do with software and the new version of remote controls. I would like to change back to Version 3.0 or earlier.
 
Had the same thing happen to me. Mine happened when I rotated the drone to change direction. It happened on 2 different drones. Both were running the 3.08 software, Assistant 3.8. I suspect it has something to do with software and the new version of remote controls. I would like to change back to Version 3.0 or earlier.
Let me know if you back up on the software version if that helped..
 
Wasn't able to change to an earlier version of software. Stuck with the latest and not so greatest. Help...
 

Recent Posts

Members online

Forum statistics

Threads
143,189
Messages
1,468,346
Members
105,096
Latest member
Andrew6669