P3 Firmware Latest firmware and Magic Powers 5/Firmware Abnormal

Joined
Nov 28, 2019
Messages
3
Reaction score
0
Age
38
I just recently updated the firmware on my P3S to v1.09.2. Everything went well. Two or 3 flights later I decided I wanted to do something about RC and video signal. I found and implemented Magic Powers 5. I turned everything up and have seen a decent increase if distance. I have noticed in the Aircraft Status screen Overall Status says Latest Firmware! Abnormal. I don't exactly when it happened it was just after MP5 install. I have had a handful of days out flying and 2 or 3 flights each day.

On an unrelated/related note, my camera gimbal starts screaming at me after startup and two beeps. Not sure if it happened around the same time as the firmware issue or not. Probably not even related.
 
Joined
Jul 26, 2017
Messages
2,301
Reaction score
1,236
Location
Irvine (Orange County) CA
Magic Power only works outside of the US and then only helps with pushing the video. If you're getting a little push on range, it's coincidental.
 
Joined
Nov 28, 2019
Messages
3
Reaction score
0
Age
38
Magic Power only works outside of the US and then only helps with pushing the video. If you're getting a little push on range, it's coincidental.

So, are you telling me that Magic Powers could or couldn't be the problem?
 
Joined
Jul 26, 2017
Messages
2,301
Reaction score
1,236
Location
Irvine (Orange County) CA
So, are you telling me that Magic Powers could or couldn't be the problem?
So, are you telling me that Magic Powers could or couldn't be the problem?
Most likely, yes. Magic Power is designed to convert the P3S from CE mode (more restricted outside the US) to FCC mode which is the standard for the US. Messing with the firmware is risky at best. I wish I had a definitive answer but I don't. There are way more experienced guys on here that may be able to assist you further.
 
Joined
Nov 28, 2019
Messages
3
Reaction score
0
Age
38
Most likely, yes. Magic Power is designed to convert the P3S from CE mode (more restricted outside the US) to FCC mode which is the standard for the US. Messing with the firmware is risky at best. I wish I had a definitive answer but I don't. There are way more experienced guys on here that may be able to assist you further.

Cool, that's good to know. Thank you. I guess my next step is going to be flashing with the latest from where again. I run that way for a while and see if the abnormal issue pops up again.
 

New Threads

Forum statistics

Threads
140,602
Messages
1,449,222
Members
102,408
Latest member
V8starlet