Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help with Motor Issue

Discussion in 'General Discussion' started by xzlr8, Oct 25, 2014.

  1. xzlr8

    Joined:
    Oct 25, 2014
    Messages:
    16
    Likes Received:
    0
    Motor sputters and led underneath does not light up. Oddly when I loosen the screws holding the motor a bit it corrects itself after a few seconds. Any ideas?

    Video here https://www.youtube.com/watch?v=STWu8bwQH0k
     
  2. RDCF550

    Joined:
    Oct 22, 2014
    Messages:
    86
    Likes Received:
    10
    Location:
    USA, VA
    The motor sputter and LEDs not turning on is an indication that the ESC in that arm is bad.

    If that thing ever had the prop guards installed, and the same screws were used after removing them, then the motor could be damaged as those screws are too long and can go up into the motor and hit the windings.
     
  3. privy

    Joined:
    Aug 14, 2014
    Messages:
    24
    Likes Received:
    0
    Location:
    Clearwater, FL
    I just had the same problem and it turned out to be a bad motor. My LEDs would light up on the initial startup but when I turned the motors on the one didn't light up. Tested by swapping with a working motor and the problem followed where I put the bad motor.
     
  4. xzlr8

    Joined:
    Oct 25, 2014
    Messages:
    16
    Likes Received:
    0
    Wanted to let everyone know that it ended up being a bad motor. Replaced it and good as new.
     
Loading...
Similar Threads - Help Motor Issue Forum Date
[HELP] Phantom 3 standard gimbal motor issue Standard/4k Discussion Jun 28, 2016
Major Motor Issues. Help Needed. Video Attached. General Discussion Aug 4, 2014
Help! DJI Phantom Motor Start-up Issue General Discussion Sep 19, 2013
Need help upgrading P3A!!! The drone motors won't start after upgrade Pro/Adv Discussion Aug 12, 2017
Standard Newbie needs help starting motors Phantom 3 Help Jul 28, 2017