Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Ground Station Waypoints Flip and Crash

Discussion in 'DJI Ground Station' started by SkyStudioCR, Apr 5, 2015.

  1. SkyStudioCR

    Apr 5, 2015
    Likes Received:
    I'm new to the forum, so thanks for any feedback or help you guys can provide to me.

    I got the DJI Datalink, installed it and had half a dozen flights with it working perfectly. The main purpose to use it, is to be able to take the same identical shot every time in real state developments, to create a time lapse video.

    While testing at home the waypoints feature with a specific heading during the hover time on a pre-recorded waypoints flight plan, my phantom 2 acted weird and between waypoint 2 and 3 it suddenly stopped, the iPad said connection lost, I looked up and it didnt continue to fly along the waypoints route.

    It actually tried to go back for a second and then forward again for another second, and right after this iPad said "GPS Mode" so connection was back. I thought everything would be normal, but less than a second after the Phantom went on a FLIP and then lost control and smashed into the ground at full power...

    I'm still trying to figure out WTF happened...

    1. It was my understanding that even if connection was lost the UAV would continue with the waypoints plan, and this evidently didn't work.
    2. Why would it go on a flip and stall and crash at full power on to the ground?
    3. Has anybody had a similar experience?

    Thanks for the help and feedback!
  2. LuvMyTJ

    Staff Member

    Feb 9, 2014
    Likes Received:
    Live! From New York!
    Sounds like something else happened. The coordinates are transferred to the Phantom prior to flight. If it loses connection that should not matter as it knows it's way. Sounds like it possibly lost GPS connection which confused it. Do you use a Flytrex module or do you DVR your telemetry? Do you recall the amount of satellites it had prior to the failure? There are a few threads here that speculate the connection to the GPS can be lost sporadicly due to a loose fitting cable. I have not followed that theory in a while so newer models may have corrected to issue. The GPS antenna is in the top of the shell. If you have ever crashed it in the past you may want to check the GPS antenna ceramic to see if it has any cracks in it.
    Flipping Phantoms sometimes indicate a motor or ESC failure. Any video of the crash?
  3. SkyStudioCR

    Apr 5, 2015
    Likes Received:
    Thanks a lot for your reply!!

    I did have 10 satellites locked in and this is 3 week old Phantom 2, so no crashes (until this event lol) and the GPS should have been working fine.

    Now that you mentioned it, I do have noticed that one of the engines makes a different sounds when I'm attaching the props before flight. Don;t know if it could be that something is wrong with or malfunctioning and that could hace caused the flip.

    However, since the accident I have put the phantom back in flight for at least a dozen flights or more with no issues. I havent really tried to test the datalink again becuase I want to get some more feeback.
Similar Threads - Ground Station Waypoints Forum Date
Dji ground station pro or litchi waypoints? Phantom 4 Help Jun 16, 2017
Ground Station Pro Max # of waypoints Software Mar 8, 2017
How to synchronise litchi saved ground station waypoints Phantom 2 Vision + Discussion May 3, 2016
Is it just "Waypoints" or "GroundStation"? (or both?) Pro/Adv Discussion Sep 14, 2015
Saving a groundstation flight plan? Saving the waypoints? General Discussion May 1, 2015