Gimbal goes limp after few seconds / no video feed / need UART info

Joined
Jun 15, 2022
Messages
1
Reaction score
0
Age
26
Hy,

I am planning to connect gimbal to UART to try and see in console what is happening...

Does anyone have pinout of grey flatcable that goes from drone to gimbal? (it must be for 4k version)? The most I`m interested in power wires and voltages.

Firmware and sd card should work with ribbon cable disconnected right?

Does anyone know what are the correct UART pins on 4k gimbal board?

Also any other information regarding to UART would be helpfull (software for console, any commands, is interface 3.3v or 5v, etc...)



LONG DESCRIPTION OF MY PROBLEM:

I had crashed my drone 2 years back. Roll arm got bent on the gimbal and plastic shell of drone was cracked...
Anyways I glued the shell and straighten the roll arm now and it is flying. Camera and gimbal were working, I had flyed several times.
Yesterday I did IMU calibration, compass calibration and gimbal calibration, inserted sd card (freshly formated on computer) .
I started flying everything was great, once I fliped camera mode from picture to video shooting, it lost video feed and gimbal went limp.

Now when I turn it on I have no video, gimbal does it`s movement and I can move it with controller until app says "Home point has been updated, you can check it on the map".
App says "No image transmission signal", video controlls are greyed out.
The dot on scale in app does follow if I move camera up / down by hand.
If I do gimbal calibrations it turns out as succesful, but gimbal does not move.
Gimbal status is "Normal" and I have no errors in app, left space on sd card is stated as 0MB, but actual free space is almost 64GB.
LED on gimbals main board blinks green rapidly for few seconds, waits for about a second and starts over. It looks to me as gimbal is rebooting itself in loop.

Gimbal does create DCIM and MISC files on sd card, the are some folders in MISC folder.
It creates a log saying:
[00000873][01 00] Firmware upgrade finished failed (step = 3, err = 0xffffffff).

This suggests that it tries to update, but sd card was empty when inserted, also DJI app always stated that it is on latest firmware and I had mobile data off, so it couldn`t download anything.

Anyways I found bin firmware file on the internet (yes, I know that this drone should be updated via app, but I managed to find firmware files).
I had tryed few versions of firmware, result is Green / red flashing LED for few seconds, then it starts flashing green rapidly again and starts over with green / red again... I had waited for 45 minutes, but no change. And the fact that it could not update anything without file or internet connection and on latest firmware got me thinking that this cannot be true... or is it?

Another thing different with bin file on sd is that drone doesn`t make log file.
LED behaviour and 0MB left statement is the same with ribbon cable disconnected and I do get gimbal errors in app.



Open to any suggestions. Thank you
 
Last edited:

New Threads

Members online

No members online now.

Forum statistics

Threads
141,961
Messages
1,459,596
Members
103,743
Latest member
Miatakoss