DJI PHANTOM 2 V3 HD-3D RC ISSUE

Joined
Nov 12, 2016
Messages
7
Reaction score
0
Age
50
Hi guys I'm a newbie here.
I have been using a DJI Phantom 2 v3 ZENMUSE H3-3D AXIS GIMBLE for nearly 3 years with out any glitches.
Recently I decided to take the bird out for a run and went through the usual pre flight steps. Calibrated compass etc.
When I initiate flight the Phantom starts and rises as per normal but at any given height between 3m and 10 it auto FAILSAFES and rises to the preset height and lands.
I have tried several different locations and get the same result.
I have FPV fitted and after the initial setup the Bird registers 10 or more GPS locks and says it is in GPS mode but on take off it auto FAILSAFES.
I have had the lid of and checked for possible wiring issues with out any luck.
I thought I would check the RC and recalibrate it using the RC Assistant software, no matter which micro USB cables I have tried the remote doesnt seem to connect.

I hope I am doing this correctly by memory
1. Connect RC to PC via Micro usb cable and turn on RC and it beep beep beeps and then my PC makes the usual "connected" sound so it appears the PC has recognised the RC
2. Open up the DJI RC assistant software and wait.
No lights appear (green and blue from memory) at bottom left hand side of software window which would normally inicate a connection.

If I connect the Phantom 2 via the USB cable and open up the Phantom 2 Assistant software my RC is recognised and I can calibrate it through the BASIC TAB options. So it appears tht there is a pairing between the Bird and RC.

I am out of ideas and have searched the WEB intensly to try and find other users that may have encountered a similiar problem but with NO LUCK.

Could it be a faulty RC? If so what RC's are compatable for me to purchase and PAIR without outlaying too many $$$ because if the BIRD has an issue than I would have just wasted more coin on a second RC.

Could it be a Compass error on the bird?

In the past I had broken the flimsy RIBBON CABLE connecting the GoPro to the Zenmuse body and this caused the BIRD to RETURN HOME before I picked up on the issue. But the RIBBON CABLE appears to be all intact and servicable?

HELP HELP HELP


Sent from my SM-G920I using PhantomPilots mobile app
 

New Threads

Forum statistics

Threads
139,513
Messages
1,439,317
Members
101,314
Latest member
GI Joe