DJI mini 2 odd thing happened!

Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
I got my Mini 2 last week, and all seems to work as expected. But I had a funny thing happened yesterday that I can't explain. I made the mistake of doing a battery firmware update with the drone sitting on my green colored garbage can. Then when I got ready to fly, the camera display had a green tint to it. I tried the auto/manual white balance settings, and I tried to reset the camera settings. Nothing worked. Everything was green! I rebooted the drone, but that didn't help. Then I turn off and rebooted the Android phone and all colors came back to normal. Then this morning, I went out to fly again. I installed the battery I used the daybefore and flew normally. No green tint. After the battery was depleted, I landed and installed another freshly updated battery. When the video came back on the screen, the green tint was back. So I rebooted the Android phone and it returned to normal. It seems that the color problem is stored in or being controlled by the battery. I don't understand that at all. Somehow it set the green tint from the garbage can as a default color. I have three batteries, but I have not tried the third one yet. Other than that everything is working great.

Can anyone explan what is happening here. I know what caused it. I should not have done a firmware update with the drone sitting on top of a green garbage can. Just rebooting the phone on the two batteries corrected it. I can't wait to see what the third one does.
 

dirkclod

Moderator
Staff Member
Premium Pilot
Joined
May 9, 2014
Messages
15,433
Reaction score
9,323
Age
66
Location
Amory Mississippi
Cant help you with that but if you haven’t you might also join
our sister forum. DJI Mavic Drone Forum
Good luck. 👍
 

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
14,786
Reaction score
8,784
It seems that the color problem is stored in or being controlled by the battery. I don't understand that at all. Somehow it set the green tint from the garbage can as a default color.

Can anyone explan what is happening here. I know what caused it. I should not have done a firmware update with the drone sitting on top of a green garbage can. Just rebooting the phone on the two batteries corrected it. I can't wait to see what the third one does.
I suspect it's just a coincidence.
The battery has nothing at all to do with the camera or colour settings.
Also if the colour of the surroundings made a difference when updating firmware, that would have been noticed by thousands of flyers already.
Whatever is causing the issue, it has nothing to do with the bin or the firmware update.
 
Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
I suspect it's just a coincidence.
The battery has nothing at all to do with the camera or colour settings.
Also if the colour of the surroundings made a difference when updating firmware, that would have been noticed by thousands of flyers already.
Whatever is causing the issue, it has nothing to do with the bin or the firmware update.
I'm sure you're right. I tested the other battery today, and it was okay. I flew all three batteries as a test, and there was no color variation. I have no idea what that was all about. But rest assured, I'm not ever going to do a firmware upgrade on a green garbage can again.
 
Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
Well, it happened again! I went out to fly the Mini 2 yesterday. I put in the first battery and when the screen came up, everything had a green tint to it. So I did the same thing I did before. I powered off the drone, the controller, and my cellphone. When everything came back up and connected, all was normal. I then flew all three batteries without any more problems. I just can't figure out what is going on here.
 
Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
I called DJI tech support this afternoon and they gave me some things to try. I flew today after I deleted the app and reinstalled it. Then the first battery I put in had the green tint to the camera image. Once again all I had to do was close the app and restart it. Then all was well again. Restarting the app fixes the problem every time, so I'm not really worried about. But I would like to find out why it is causing it. I'm beginning to think it has something to do with the Android phone. I'm going to get another Android phone and see what happens then. I have a work phone that I can use, but all of my batteries are recharging right now. I'll try it tomorrow. The interesting thing is that this started right after a firmware update. As I stated in my first post, I made the mistake of doing the update while the drone was sitting on a green garbage can lid. I flew several times before the update and it was all normal.

My app is version V1.2.1. The web page says that the latest version is v1.2.4. Even after deleting and reinstalling the aap, it is still v1.2.1 on my phone.
 

dirkclod

Moderator
Staff Member
Premium Pilot
Joined
May 9, 2014
Messages
15,433
Reaction score
9,323
Age
66
Location
Amory Mississippi
If your IOS try going into apps and totally delete it. Then download it again. I had to do that with one of my MP’s for what issue I can’t remember but that fixed that issue. 🤷‍♂️
 
Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
If your IOS try going into apps and totally delete it. Then download it again. I had to do that with one of my MP’s for what issue I can’t remember but that fixed that issue. 🤷‍♂️
I did delete the app this afternoon and then installed it again off of the web site. I'm also going to try a different Android phone tomorrow. I installed the app in it tonight.
 
  • Like
Reactions: dirkclod

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
14,786
Reaction score
8,784
As I stated in my first post, I made the mistake of doing the update while the drone was sitting on a green garbage can lid.
That wasn't a mistake, it was a coincidence.
If the colour of your surroundings for an update made any difference, thousands of flyers would have had the same issue in the past.
If you have access to another drone that uses the Fly app, you could try that and possibly eliminate the phone and app as suspects
 
  • Like
Reactions: dirkclod
Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
That wasn't a mistake, it was a coincidence.
If the colour of your surroundings for an update made any difference, thousands of flyers would have had the same issue in the past.
If you have access to another drone that uses the Fly app, you could try that and possibly eliminate the phone and app as suspects
You might be right. I just don't know what is happening. But as I said above, it is easily correctable by just restarting the phone. I could not run further tests yesterday because I was charging all three batteries. But today I'm going to test it again. I did put the app on another Android phone, So I'm going to try the other phone as well. Also, I'm going to power up the drone and controller first, then open the app. I'll see what that does.
 
Joined
Jun 29, 2016
Messages
345
Reaction score
147
Location
California City, California, USA
I flew the m2 again today. I did not have any problems at all! It was a perfect dog-leg flight out to 7,600 feet and back. This time there was no video green tint at all. The only thing I did different was waited until the remote and the drone were both powered up before I opened the app. Oh, and I did reinstall the app yesterday. I only flew one battery down to 45%. I'll try the other batteries when I get some time.
 
  • Like
Reactions: MTO and dirkclod

New Threads

Forum statistics

Threads
140,619
Messages
1,449,372
Members
102,427
Latest member
ldti