Advanced DJI GS Pro - Please connect to RC

Joined
Sep 24, 2020
Messages
10
Reaction score
1
Age
61
Hello,

I was out on construction site in the late morning sun, hot here in CT.

This is probability the 25th automatous flight with this Mission on the DJI GS Pro app with the same iPad. Last flight was two weeks ago, no issues. I haven't done any firmware updates the past year. Same startup sequence, but had to use my phone as a hotspot (one of a few times) due to the map not showing up on the DJI GS Pro app. I have the DJI GO app open as usual to do a full check system and battery and to observe the warmup and "Ready to Fly" comes up.
Switch back to DJI GS Pro app and I see the blue text and Phantom 3 at the upper left corner and Connected to "Bird" at bottom. I can see the camera view in the DJI GS Pro screen as with the DJI GO app. Selected my mission and then Fly. "Prepare for flight" dialog comes up and all items come up green as mission is uploaded to the drone. However the top most line for Connection says "Phantom 3 Please connect with RC". Uh? And the usual "No obstacle Avoidance system. (Using F Mode)

So I switch to the DGI GO app when check out everything, looks normal with camera and all. So I tested by launching and checking all flight control inputs, then RTH (from the screen not RC). Everything works. The bird is connected to the RC and the RC shows a green light as well.

So why is there a "Please connect to RC" in the GS Pro app so no joy in the automatous flight but there is full operation of the bird with manual inputs with the DJI GO app?

Thanks all
 
Joined
Aug 17, 2014
Messages
1,474
Reaction score
706
Location
Long Island, NY
Could be because you are running with both apps open. I know you can run into problems if both DJI GO and Litchi are running at the same time, so maybe your situation is similar. I'd recommend closing the DJI GO app entirely (don't just switch back and forth) before opening, connecting, and launching with the DJI GS Pro app.
 
Joined
Sep 24, 2020
Messages
10
Reaction score
1
Age
61
Could be because you are running with both apps open. I know you can run into problems if both DJI GO and Litchi are running at the same time, so maybe your situation is similar. I'd recommend closing the DJI GO app entirely (don't just switch back and forth) before opening, connecting, and launching with the DJI GS Pro app.
Thank you, I will leave Go Pro off and just start with GS Pro app. Its not been a usual issue. But I may have started the GO Pro app first to do a preflight check.
 
  • Like
Reactions: MapMaker53
Joined
Aug 17, 2014
Messages
1,474
Reaction score
706
Location
Long Island, NY
Thank you, I will leave Go Pro off and just start with GS Pro app. Its not been a usual issue. But I may have started the GO Pro app first to do a preflight check.
Hopefully that resolves it.
 
Joined
Sep 24, 2020
Messages
10
Reaction score
1
Age
61
Hopefully that resolves it.
Alas, no that wouldn't work. Even shutting down the iPad and then restarting everything with just DJI GS Pro results in same state of abject sadness.

Just for fun I relinked the AC to the RC and same issue. I was asked to do a Remote Controller Calibration. Anyway I can be linked and fly manually with DJI GO. It's just the DJI GS Pro that will not link. See screenshots.

Then I deleted the app and reinstalled it.
Anyway this is what I am seeing before i can launch a mission. Joy, joy, joy.
RC Link 0.jpg

Tried to do the Remote Controller Link through the DJI GC Pro. Note these are grayed out.
RC Link 1.jpg

DJI GO has no issues to report.
RC Link 2.jpg



Would love to get this done so I can fly a scheduled mission this Wednesday.

Thanks,
David
 
Joined
Sep 24, 2020
Messages
10
Reaction score
1
Age
61
Well after a on line chat with DJI Consumer support who asked that I give contact information, DJI's Enterprise group is supposed to reach out. It's been a week or so...
Meantime I sit and ruminate over this.
 

New Threads

Forum statistics

Threads
140,752
Messages
1,450,506
Members
102,587
Latest member
Blufx