Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Compass Calibration Fails: MOD Value always too low!

Discussion in 'Phantom 1 Help' started by legalbrr, Sep 13, 2013.

  1. legalbrr

    Sep 13, 2013
    Likes Received:
    Hello everyone!

    I bough a Phantom about 1 month ago, and it's just amazing flying it, really nice equipment!

    However, since it arrived, I NEVER succeded the compass calibration process.
    Believe me, I tried EVERYTHING, watched tons of videos and read all how-tos you can imagine.
    Light always go green, and the quick-flashing red (meaning calibration failed).

    The "Status" light, 90% of the times keep flashing "red/yellow", indicating that compass cannot be used.
    However, 10% of the times, it just goes green as it should (although calibration process still fails).
    When it is working (green flashing), and I switch to GPS mode (even without previous calibration), some things occurs, depending on the time of the day and the location I am:
    1)Sometimes, phantom chooses a side and just keep going to that side, as if the GPS says "Go to Arabia!";
    2) Sometimes, phantom starts drifting in circles around the "desirable" spot it should stay, but each time radius gets increased;
    3) Only one time (I tried over 40 times), it a perfect condition (completely isolated place, good weather, no wind), GPS worked as expected (stop means stop, stay means stay and go home means go home...).. But even in this condition, calibration process still failed!
    * Important to say that, after "losing control" in GPS mode, I always switch to ATTI to regain control.

    Please understand:
    - I did a LOT OF RESEARCH, trying to fix it;
    - I work with computers and software development, and I am an enthusiast of electronics, so I know the basics;

    That said, when I plug the Phantom to the NAZA-V2 software, it shows me a popup saying that compass error is too big.
    However, while watching the "Compass MOD" values, they are TOO LOW (100-250).

    Everywhere I look, including the DJI COMPASS CALIBRATION videos, the calibration with another magnet should be done to help REDUCE the MOD withing the desirable range (1400 to 1800). In the video example, after he mess things up, his mod goes to over 2800/3000! Then, he does circles around the compass using another magnet to reduce it to a acceptable range.

    Well, I tried that (god knows how hard I tried... for three days, over 3 hours). I used a magnet removed from a dead hard-disk, and did circles around the compass. The MAXIMUM "MOD" value I got was 750... But when getting 750 as mod, X/Y values when absolutely crazy (-780 for example).

    So, when trying to fix X/Y, mod also got back to lower values.

    AFTER A WHILE, I figured out: "The compass is the problem! I will have to replace it, of course!"

    So, I bought a new landing with compass module, that arrived today.
    I was VERY careful this time, so I would not get close to any magnet (screwdriver, car speakers ,etc.).

    Before even trying to fly, I plugged the phantom to my computer again and.. Oh no!! Value is 300.
    And red/yellow lights, no GPS mode available at all.

    I live in Brazil, the first Phantom I bought from a local dealer.
    The compass module I bought from a Hong Kong store, that shipped me via EMS.

    I don't know if this problem is caused by some X-RAY machine on the airport, or what else could be the cause of the problem!

    The worst part, is that I don't find anybody else having the same problem with LOW MOD VALUE, everybody who complains about mod value have it too big!
    Can anyone give a little clue of WHAT IS GOING WRONG!?

    Ps: Using firmware 3.16, and I did import the "default configuration parameters", and tried a lot of other things inside the software.

    Thanks, and let me say that I am glad to be a new Phantom Pilot!
  2. will27

    Jul 22, 2013
    Likes Received:
    Try turning the IOC off in your Naza Assistant software, then do the compass calibration. When you are finished hook it back up to the computer and turn the IOC back on. That's the only way I can do it with my Naza Lite controller.
  3. halfpipe

    May 14, 2013
    Likes Received:
    Atlantic Coast Canada
    keep repeating the compass calibration procedure until sucess. Make sure to reboot between each attempt.
    Maybe move to various locations because won't calibrate if you are standing on iron which might be in the ground naturally
  4. Mike1390

    Sep 21, 2013
    Likes Received:
    Hey Charles have you taken it over to dronefly? They are in Newbury Park super nice guys always to help out.
  5. Mike1390

    Sep 21, 2013
    Likes Received:

    What is your set up?
    I'm also in Thousand Oaks.
Similar Threads - Compass Calibration Fails Forum Date
Phantom1 compass calibration fails Phantom 1 Discussion Jul 12, 2014
Compass calibration fails Phantom 1 Help Jul 26, 2013
Compass Calibration General Discussion Aug 15, 2017
Compass calibration Phantom 4 Pro Help Aug 8, 2017
Standard Compass Calibration Phantom 3 Help Jul 27, 2017