Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Can't update firmware, tried (almost) everything P3-A

Discussion in 'Phantom 3 Help' started by duuffman, May 11, 2016.

  1. duuffman

    May 11, 2016
    Likes Received:
    Hey guys,

    I have a problem with my phantom, here i will try to explain:

    I have a PHantom 3 Advance, bought it May 2015. I did never update it after the first purchase. When traveling with the drone, day 4 or 5 i crashed it intto a tree, drone kept working, 0 problems, just one of the arms has some damage, but just in the external shell.

    Ok, drone kept flying for 1 month (i used it about 25 more days, flying almost every day, with more than 15-20 fly hours), at the end of my travel, it stoped working while i was in Hong Kong, i could not see image from the drone on my phone (samsung galaxy s5), but the drone could fly normally. I tried to restart the drone and remote, and recalibrate and all that, but id did nothing.

    I went back home, and tried to update it with the firmware from that time, (August 2015 iirc) failed.

    I was very busy the following months, so i kept it in its box until now.

    I've now tried to update it, but i never can.

    I have succesfully updated my remote (version 1.6)

    I have tried to uptade 1.32, 1.7, 1.8... nothing.

    I format the SD card in fat32, and exFat, nothing.

    I tried a 2gb, 16gb (included with P3) 32 GB, a 64 GB... nothing

    I download the correct version (for advance model) for windows, i format the SD card in the PC (i have also tried to format with the DJI GO app), then copy to the main root the .bin file, and then i inset it to the phantom, with a fully charged battery (remote closed). It starts beeping, but not the D-D-D sound i hear in tutorials, and also the camera central led light (the small one that should blink red and green) only blinks green from time to time. Also, some times i have tries to update it, the camera falls off all of a sudden, for a while.

    I let the drone for 40-50 minutes eventhough it is not doing the D-D-D sound, just in case it is actually updating, and it does nothing.

    I conect the remote and the DJI go app, and i can see no image, and it says "format SD card recomended" (already tried it several times, from the PC and through the app) nothing.

    I also tried reinstaling DJI app many times

    I am quite desperate now, as i don't know what else to do.

    Sorry for my bad english and the long post, i am from Spain.

    Hope you can help me up, as i am about to throw it to the bin.

    Thanks in advance! (advance.. how ironic )
Similar Threads - Can't update firmware Forum Date
Can't open P3X file to update firmware Pro/Adv Discussion May 17, 2017
Can't update firmware or change gain Pro/Adv Discussion Feb 12, 2017
Professional Firmware update failed, can't see live camera feed Phantom 3 Help Jan 10, 2017
Help!! Updated firmware and can't get RC to connect Phantom 3 Help Jan 1, 2017
Standard Can't install firmware update ; Blank screen on Overall Status Phantom 3 Help Dec 24, 2016