Unstable hovering

Joined
Aug 12, 2015
Messages
30
Reaction score
2
Age
49
My P3P has over the months began to move a lot more when hovering - noticeably so.
The calibrations and firmware are up to date - anyone else experiencing this and if so have you found any fixes. ?
Thank you


Sent from my iPhone using PhantomPilots
 
  • Like
Reactions: Hellhunter
Joined
Jan 4, 2016
Messages
7,825
Reaction score
3,091
Location
Australia
My P3P has over the months began to move a lot more when hovering - noticeably so.
The calibrations and firmware are up to date - anyone else experiencing this and if so have you found any fixes. ?
Thank you


Sent from my iPhone using PhantomPilots
Move a lot lot more than what? How much movement are we talking about? Horizontal drift at altitude changes? How high off the ground? Wind?
 
Joined
Sep 24, 2016
Messages
14
Reaction score
0
Age
16
I have the exact same problem as well, any help would be appreciated (and by the way there is no wind)


Sent from my iPad using PhantomPilots
 
Joined
Nov 1, 2014
Messages
199
Reaction score
42
Location
Nome,AK USA
My P3P has over the months began to move a lot more when hovering - noticeably so.
The calibrations and firmware are up to date - anyone else experiencing this and if so have you found any fixes. ?
Thank you


Sent from my iPhone using PhantomPilots
Mine is drifting as well, close to the ground, while hand catching.
15-20' horizontally.
Almost hit a car, but luckily the drone was hovering at an elevation above the car roof.
No wind.
 
Joined
Jan 10, 2016
Messages
2,513
Reaction score
814
Location
Surrey, England
If you've started experiencing these issues when everything was OK, then I think you all need to FULLY recalibrate your ACs. I suddenly had a slight drift, vibration and weido issues with the gimbal some months ago and, as advised by experienced people here, a full recalibration of the AC solved the problem.
 
Joined
Sep 24, 2016
Messages
14
Reaction score
0
Age
16
If you've started experiencing these issues when everything was OK, then I think you all need to FULLY recalibrate your ACs. I suddenly had a slight drift, vibration and weido issues with the gimbal some months ago and, as advised by experienced people here, a full recalibration of the AC solved the problem.
Thank you so much, I'll be sure to try it


Sent from my iPad using PhantomPilots
 

New Threads

Forum statistics

Threads
136,140
Messages
1,408,062
Members
99,058
Latest member
Cherry