Random ATTI mode 2 times in one flight

Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
I was flying yesterday and the P3A went to ATTI mode unexpectedly for about 5 - 10 seconds. Then it reestablished P mode. It happened twice the same way. I have flown this bird maybe 10 times and I bought it new. Prior to starting the flight I did compass calibration. I had full battery and full satellite positioning. I was about 2000 feet downrange. It happened at about the 10 second mark. The K-index was OK yesterday. Minimal wind (5 mph). What do I need to do to troubleshoot this?

 
  • Like
Reactions: Webby
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
I only calibrate it when I go more than 50 miles from the last calibration location. Is that the standard?
 
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
I was in a park, no buildings nearby. The closest car was probably 50 feet away. The only metal object that can recall that was anywhere near me was a metal railing, which was 6 feet away. Is that a potential problem?
 
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
I will do a better job in the future searching the posts before creating a new one.
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,376
Reaction score
3,149
Location
Western US
I was flying yesterday and the P3A went to ATTI mode unexpectedly for about 5 - 10 seconds. Then it reestablished P mode. It happened twice the same way. I have flown this bird maybe 10 times and I bought it new. Prior to starting the flight I did compass calibration. I had full battery and full satellite positioning. I was about 2000 feet downrange. It happened at about the 10 second mark. The K-index was OK yesterday. Minimal wind (5 mph). What do I need to do to troubleshoot this?

We have seen a sudden spike in reports of P3s rapidly switching between ATTI and GPS modes often combined with an increase in reported compass errors. If you don't mind, would you please let us know exactly which versions of FW you have on your AC and your RC as well as which version of the app? Please just don't say "latest" since that leads to guessing. Since compass issues are so serious, we'd like to be able to find something common in all of these sudden reports. Thanks.
 
Last edited:
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
App 3.0.2
AC 1.9.60
RC 1.8.0

I did another compass calibration "by the book". Upon launching and getting up to about 75 feet, ATTI mode again for about 5 - 10 seconds, then it reestablished P mode and I continued flying.
 
Joined
Jan 10, 2016
Messages
2,513
Reaction score
814
Location
Surrey, England
App 3.0.2
AC 1.9.60
RC 1.8.0

I did another compass calibration "by the book". Upon launching and getting up to about 75 feet, ATTI mode again for about 5 - 10 seconds, then it reestablished P mode and I continued flying.
Weird...
Can you see if it does it if you just T/O and leave it in hover 10 feet up?
Also try taking off in ATTI mode and then switching to P. If it doesn't switch to ATTI , try T/O again in P and see what happens. I had a similar issue a while back and this was what I did. Never had a problem since...
 
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
I will start doing that.

At this point, considering I have done the compass calibration "by the book", I wonder if I should trust this bird? Random ATTI mode is disconcerting and not something I think I should live with.
 
Joined
Jan 10, 2016
Messages
2,513
Reaction score
814
Location
Surrey, England
I will start doing that.

At this point, considering I have done the compass calibration "by the book", I wonder if I should trust this bird? Random ATTI mode is disconcerting and not something I think I should live with.
Just try my suggestion and see if it works.
 
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
OK, I hovered with no problem. Then I flew for about 15 minutes uneventfully. I switched to ATTI mode, flew for a couple of minutes, then back and P mode with no problems, nothing unusual. I will continue to monitor the issue.
 
Joined
Jan 10, 2016
Messages
2,513
Reaction score
814
Location
Surrey, England
OK, I hovered with no problem. Then I flew for about 15 minutes uneventfully. I switched to ATTI mode, flew for a couple of minutes, then back and P mode with no problems, nothing unusual. I will continue to monitor the issue.
OK, so you took off in ATTI? If not, please do this too and keep it flying locally (for your own piece of mind!) for a few minutes and then switch to P and it should now remain in P mode. Then for a final time just T/O manually in P; hopefully, you'll have it fixed.
 
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
Thanks. I will take off in atti mode and follow the instructions. Sorry I did not do that already. I know it is frustrating taking the time to provide instructions and I did not follow them. I will do better in the future.


Sent from my iPhone using PhantomPilots
 
Joined
Jan 10, 2016
Messages
2,513
Reaction score
814
Location
Surrey, England
Thanks. I will take off in atti mode and follow the instructions. Sorry I did not do that already. I know it is frustrating taking the time to provide instructions and I did not follow them. I will do better in the future.

Sent from my iPhone using PhantomPilots
LOL! No frustration. I just want to make sure it you do everything to try and fix your issue, mate!
 
Joined
Sep 16, 2015
Messages
47
Reaction score
8
Age
57
I successfully took off in ATTI mode, flew for about 5 minutes, then switched to P mode. I have since flown the bird about 6 times. For the most part the flights maintained P mode, although today the P3A reverted to ATTI mode randomly for a couple of seconds each time, then reverted back to P mode. So still have no explanation for this behavior. I did switch to ATTI mode while in flight and back to P mode successfully several times.

One good thing that has come from this experience is that I am not longer intimidated by ATTI mode.

Does DJI allow dealers such as Carolina Dronz do diagnostics under warranty? Or does that have to go directly to DJI?
 

New Threads

Forum statistics

Threads
136,109
Messages
1,407,682
Members
99,043
Latest member
JbroDrone