P3S green link led, RC red link led

Joined
Jun 11, 2024
Messages
7
Reaction score
4
Age
28
Hello,

I recently bought this P3S and when I came home with it I have seen that the app could not connect with the camera live feed.
After some investigations I descovered that the RC was not linking with the AC.
On the AC the link led is green but on the RC it is red.

I cannot connect it with the AC but I can move the ghimbal.
I have tried downgrading it but halfway it stops and it's saying that it cannot be downgraded because the current firmware doesnt support it.
I am thinking that it might be a mismatch in the firmwares of the AC and RC but I cannot do anything to change them

The RC controller is GL358wA and the only way to change the software is through the app.

Please guys help me out ,
 
Suggest you manually relink AC and RC. There are instructions on how to do this in the DJI P3S manual available online. It is also available on msingers site Phantomhelp.com Be SURE to select the "P3S Standard" section. The manual download is just a few inches down the page at "MANUAL--Phantom Manual" The linking procedure is on page 24 of the manual

I would advise NOT to upgrade/downgrade firmware until it is absolutely necessary.. Many great flying drones have been bricked by unsuccessful updates. (case in point....I haven't updated the firmware on my P3S's since 2016 (1.5.70)

Also, fill us in on what App version you are using, and the mobile device you are using......plus any other info that may help us figure this out.
 
  • Like
Reactions: alexcr and RodPad
Welcome to the Forum!

@captainmilehigh
Yes don't mess with the firmware!!

Look at my signature.

#1 You can move the gimbal with the RC or the App?
#2 You don't need the App to link the RC to the AC.

As stated more info.

Are you sure it is a PS3?
On this forum, I have seen the wrong shell, on a P3*

I recommended going to @msinger 's Help.
There is a drop down you can see all P3* models.

Hope you come back :)👍

Rod



.
 
Hey guys, thank you for replying.

I have already tried any type of linking.
I will attach photos with the problem.

The RC and AC are ON and the Led is green wich mean connected with the RC

01.jpg


RC on red led mean no AC connection

12.jpg


The gimbal was moved with the RC in this state
3.jpg
4.jpg
down and then up.

It is the only thing that is responding through radio but when I look in the app and I calibrate it every control works just fine.
 
Welcome to the Forum!

@captainmilehigh
Yes don't mess with the firmware!!

Look at my signature.

#1 You can move the gimbal with the RC or the App?
#2 You don't need the App to link the RC to the AC.

As stated more info.

Are you sure it is a PS3?
On this forum, I have seen the wrong shell, on a P3*

I recommended going to @msinger 's Help.
There is a drop down you can see all P3* models.

Hope you come back :)👍

Rod



.
Suggest you manually relink AC and RC. There are instructions on how to do this in the DJI P3S manual available online. It is also available on msingers site Phantomhelp.com Be SURE to select the "P3S Standard" section. The manual download is just a few inches down the page at "MANUAL--Phantom Manual" The linking procedure is on page 24 of the manual

I would advise NOT to upgrade/downgrade firmware until it is absolutely necessary.. Many great flying drones have been bricked by unsuccessful updates. (case in point....I haven't updated the firmware on my P3S's since 2016 (1.5.70)

Also, fill us in on what App version you are using, and the mobile device you are using......plus any other info that may help us figure this out.
hey I have attached photos with my answer on another post beneath this one

sorry I dont know how to use the forum I am new. :D
 
That's ok. We were ALL new at this stuff at one time.

Sounds like the RC is not connected to the GoApp. To be sure, follow the directions in the manual on pages 25 and 26 to link the RC to the App. The video screen should show that they are connected.
 
  • Like
Reactions: RodPad
Need the Facts, My totaled I bought brand new.P3S, the link light is on the bottom, Just looked what do you have?

Rod .
 
That's ok. We were ALL new at this stuff at one time.

Sounds like the RC is not connected to the GoApp. To be sure, follow the directions in the manual on pages 25 and 26 to link the RC to the App. The video screen should show that they are connected.
They are connected, it is saying remote connected, connect the aircraft and I cannot connect...
 
Need the Facts, My totaled I bought brand new.P3S, the link light is on the bottom, Just looked what do you have?

Rod .
yes I have a P3S too and the link is on the side bottom left (looking in front of the camera)
 
yes I have a P3S too and the link is on the side bottom left (looking in front of the camera)
Yep. Same place mine are.

Let me backup a bit here. Have you ever seen this drone work correctly, or have seen the drone ever connect as normal......with green rear LED's and 'ready to fly' on the App?

In summary, I am concerned about these two points:

(1) If the P3S was purchased without a demonstration 'test flight'. And,
(2) If a firmware update or downgrade was attempted with a failed result, did that corrupt the existing firmware?
 
Last edited:
IMG_4857.JPG
IMG_4858.JPG
IMG_4859.JPG
IMG_4860.JPG

I think there is a image limit.

Rod ..
 
IMG_4861.JPG
IMG_4862.JPG
IMG_4863.JPG

Second picture in this post, that's where this one is. It is a light and button side by side on the mother board. I remember some posts in the past somebody posted a picture of the motherboard.

Probably doesn't helps the problem, but I can sleep tonight!!

Rod ..
 
  • Like
Reactions: captainmilehigh
Yep. Same place mine are.

Let me backup a bit here. Have you ever seen this drone work correctly, or have seen the drone ever connect as normal......with green rear LED's and 'ready to fly' on the App?

In summary, I am concerned about these two points:

(1) If the P3S was purchased without a demonstration 'test flight'. And,
(2) If a firmware update or downgrade was attempted with a failed result, did that corrupt the existing firmware?
1) Yes I bought it without a test flight
2) Downgrade, it runs for a while then it stops and in the file with the result this is what I have:
"The current firmware does not support downgrade. Use a different version of firmware to downgrade the target version."
3) Why I can control only the gimbal and the rest of the AC not?
4) Why the AC has the linked led green and the RC's led is red(as in not linked)?
 
  • Like
Reactions: RodPad
The gimbal works anytime the AC and RC are both powered on. It should do the startup 'gimbal dance' even if only the AC is powered on.

If you push the AC link button, does it turn red and blink indicating that it is ready to link to the RC?
 
  • Like
Reactions: RodPad
The gimbal works anytime the AC and RC are both powered on. It should do the startup 'gimbal dance' even if only the AC is powered on.

If you push the AC link button, does it turn red and blink indicating that it is ready to link to the RC?
1) Yes it does the dance, and after the dance I can control it up and down.
2) Yes it start flashing red and when I try to link the controller with it it never links. the controller keeps on beeping.
 
  • Like
Reactions: RodPad
@captainmilehigh

His picture still messes with my head. :)
I'm going to watch how this thread goes for now.

I know the pay is good 👍 :)👌

Rod ..
 
  • Like
Reactions: captainmilehigh
@captainmilehigh

His picture still messes with my head. :)
I'm going to watch how this thread goes for now.

I know the pay is good 👍 :)👌

Rod ..
Yeah, I'm thinking messing with the firmware might have corrupted the onboard firmware since it failed to complete. And, if the bird and RC don't link up there may be a bigger issue here. But, I like a good mystery. We will see where this goes............;)

.....pay?..............hahaha..................you so funny :D:D
 
  • Love
Reactions: RodPad
Hum, just back for a look see, yep same as me, love the mind challenge!
I need to reread these posts, find something I think I may have been in my 6K posts. OMG!

Rod ..
 

Recent Posts

Members online

No members online now.

Forum statistics

Threads
143,189
Messages
1,468,346
Members
105,096
Latest member
Andrew6669