Linking P-RTK2 and P4 RTK

Sep 27, 2022
Reaction score
Hi All,

I'm having quite a bit of trouble with this P4RTK kit I bought, second hand but never used. I can't get it to link to the D-RTK2 station. I'm really hoping someone can help me here, as I've been trying for 2 days including with my drone spraying friend who uses all this gear, and I'm just getting nowhere.

I've been through the firmware, both on the app and today I hooked it up to Assistant 2. Here's what I have:

GS RTK. Version V2.18-GSP

P4RTK drone. Version 02.02.0608 Assistant 2 says this is the latest version.

D-RTK mobile station. Version 03.01.0000. Assistant 2 says this is the latest version. I thought of rolling it back but it won't let me now.

P4RTK standard controller. Version 02.03.0330. This is where it gets strange. In Assistant 2 there's the option to upgrade to version 03.01.0000, and when I do it it says it was successful but then when I check the version I'm back at 02.03.0330. When I turn it on I get the message about the drone and controller being mismatched, and to connect it to the computer to upgrade, but when I connect the drone it only offers version 02.02.0608. There's no offer to update it via the app.

The D-RTK2 mobile station has been back to DJI for a warranty repair, which they did. It wasn't turning on and they replaced the battery connector apparently. It's now turning on and getting a green light/RTK lock. It also goes into linking mode with the push of the button. My mate was able to connect his Agras T30 to it on mode 5, and I'm trying to connect the P4RTK on mode one (single green flash) as requested by the controller.

I've tried everything... initiating the linking via the home screen/top left 3 bars. Going into the flying menu and settings then turning on the RTK and selecting mobile station. I've tried single and multiple linking options as well, and tried to link with the drone on and off. Nothing has worked.

Is there anyone out there who can advise me what to do here? What firmware versions should I have in all the components? Is there another version of Assistant I don't know about? I've used both Assistant 2 for Phantom and MG series, and they both gave the same results. I'm at a complete loss as to what's going on there.

If there's anyone out there who could help me through this, I'd be really grateful. I've got a ton of money tied up in this and an Agras drone, and I can't get it to work. It's crazy.

Thanks in advance for any assistance. I'll put this in the commercial forum as well, and might even sign up for the DJI forum as well for what it's worth.
Have you tried your P4RTK with his D-RTK2 and/or GS controller if it is compatible? Maybe it's the bird and not the station?
Have you tried your Agra instead of his Agra, his Agra with his GS and then your GS, etc etc.
I assume your P4 works in all other aspects, GPS, mapping software?
I do not, btw, have any of this equipment, so I am just going thru what my list of trouble shooting would entail, trying each component with other combinations to narrow the problem down to one component, and then trying to narrow it down to a part problem or a software-firmware issue.
Good luck.
Last edited:

Recent Posts

Members online

Forum statistics

Latest member