Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

assistant won't open - please help

Discussion in 'Phantom 2 Help' started by raven's eye media, Jul 26, 2014.

  1. raven's eye media

    Jul 26, 2014
    Likes Received:
    I have the Phantom 2 and a Mac. Everything has been working great but I went into PT2 and RC to calibrate and to switch to ioc. I also slowed the gain on the gimbal roll. At some point it suggested firmware upgardes so I completed them (not sure what they were at this point) but my flysight monitor started acting wonky. My image all of a sudden was skipping. There are bars scrolling through my screen constantly and I can't really see the image clearly. What happened?

    Flew it in cl mode and everything worked great except the monitor. I have tried everything. I switched to a new video transmitter, checked connections, bypassd anti-interferance board, replaced ribbon cable in gimbal (which was a pain in the ***), and I tried a new gopro. None of these made a difference to the monitor.

    So I started researching how to downgrade firmware as that is the only thing I did that may have caused the monitor to go crazy. I started experiencing problems with the PT2 and RC apps so I uninstalled them and re-installed them on my mac os. Now when i connect the assistant opens but gets stuck unless I press skip. But if I press skip it opens assistant with blank readings. The usb is connected, the power is on and I hear it connect (chime).

    After speaking to my dealer for 2 hrs he had me install parallels and windows 7 on my mac as he said dji is not mac friendly. I completed all of this and installed the WIN installer and assistant. When I open thees apps through windows I get the same problem! It just gets stuck unless I click skip.

    I also bought an iosd mini and installed it but before I closed the body up I tested iosd assistant and same problem. Gets stuck. So now I have taken the iosd mini out and hooked everything back up the way it was for the last couple months. Video transmitter, gimbal to anti-interferance, etc.

    I've been trying to find a solution for 10 hours and have hit a dead end. Does anyone have any ideas? At this point I am just trying to open PT2 and RC to check settings and see if it flies. I'll deal with the monitor craziness later I guess. I have worked really hard to get this thing to perform the way i need it to and I was pretty much there. Here is a demo of some shots I got. https://vimeo.com/101758114

    Please advise and Thanks!
  2. Buk


    Feb 28, 2013
    Likes Received:
    Iowa, United States
    First a comment, I use a Mac with a Phantom 2 (non vision) and the two software packages work just fine. The only thing I may have to do is switch USB ports I use on the Mac, one works with the Phantom/RC software and one does not.

    Make sure your Black Pearl is set to NTSC and that your GoPro is too. The scrolling sounds like a mismatch. (Set them both to PAL, if that is what you use).

    It's not unusual to have to hit "skip" if they aren't talking to each other (Mac & Phantom or Mac & RC), try switching USB ports on the Mac. Try changing the order you plug things in and turn them on.

    If you really want to use windows on your Mac, again try plugging into different USB ports on the Mac.
  3. nintendrone64

    Feb 19, 2014
    Likes Received:
    Simi Valley, CA
    Man, that's pretty random! Normally a update SHOULD NOT do that.
    I would have to agree - check if maybe it accidentally reverted to the default settings.
Similar Threads - assistant won't open Forum Date
[Solved]Phantom 2 assistant won't connect after motor replacement Phantom 2 Help May 3, 2017
RC Assistant won't react to the RC? Software Jan 7, 2017
DJI Assistant 2 Won't Connect Phantom 4 Help Jan 2, 2017
Motors won't turn, but Assistant says calibration not needed Phantom 1 Help Jul 11, 2015
Assistant software won't recognize my controller Phantom 2 Vision Discussion Jun 29, 2015