Camera not powering on

Joined
Jun 3, 2015
Messages
15
Reaction score
1
Age
26
So it seems as am not having a good day at all ...From my previous post early on i was able to fix those problems now am back with another with my camera,which all of a sudden it stop works or even comes on ...today i ran into some problems with the range extender not picking up which i corrected now its down to a camera power problem!!!
 
Joined
Apr 10, 2014
Messages
2,276
Reaction score
1,250
Age
47
Location
Sarasota, FL. USA!
If you tried messing with the wire while phantom was ON, could have burnt the MC?

Here is a picture of a burnt one,


Requires you to open top and look on main controller board right by cam plug, like in picture! If this is the case, you'll need to replace your MC!

J Dot
 
  • Like
Reactions: dirkclod

dirkclod

Moderator
Staff Member
Premium Pilot
Joined
May 9, 2014
Messages
14,310
Reaction score
7,873
Age
64
Location
Amory Mississippi
I came back to your previous thread as I said I would and saw you hadn't been back and ya never said you had solved it .
Now you say you have and have another Issue . Would be nice for all involved to know just what fixed your other problem
in that thread so it might help others with the same thing .
Now.... more info on what it is going on and what you have tried to do to with this.
Are all the cables hooked up and The switch above the sd card slot all the way to the right ?
 
  • Like
Reactions: J Dot
Joined
Jun 3, 2015
Messages
15
Reaction score
1
Age
26
Sorry for long reply but i was in and out ...Currently the cam is work all of a sudden idk what may be causing this on and off problem but i think i will have to replace the cam
 
Joined
Feb 4, 2015
Messages
40
Reaction score
5
Location
Budapest, Hungary
Hi J Dot!

My mainboard looks like what you've linked (see my picture). Sometimes i have fpv sometimes not but the recording is ok. You said should be change the MC, but the MC isn't it the black boxy thing?

Thanks in advance!
DSC00786.JPG
 
Joined
Apr 10, 2014
Messages
2,276
Reaction score
1,250
Age
47
Location
Sarasota, FL. USA!
Hi J Dot!

My mainboard looks like what you've linked (see my picture). Sometimes i have fpv sometimes not but the recording is ok. You said should be change the MC, but the MC isn't it the black boxy thing?

Thanks in advance!View attachment 24258
Hello,
Yes it looks burnt, this is caused by either unplugging camera with it powered on, or a short somewhere?
You might have to replace the whole main Controler board, or possibly find an electronics expert to repair your circuit board, you might want to replace the white camera wire as well, it is like $11 U.S. To replace cable, MC IS AROUND $60. Or go into classifieds, maybe one of our awesome members has a wrecked phantom or parts for you cheaper? If not eBay might be a better route!
Sorry that happened to you, but those cameras are touchy when plugged or unplugged with phantom powered ON! Hope this helps!

Take care, fly safe!
J Dot
 
  • Like
Reactions: dirkclod and TheCif

New Threads

Forum statistics

Threads
135,378
Messages
1,400,710
Members
98,611
Latest member
Machazareel