Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

New Vision+, Lose GPS lock/half satellites when recording?

Discussion in 'Phantom 2 Vision + Discussion' started by cstradling24, Sep 25, 2014.

Thread Status:
Not open for further replies.
  1. cstradling24

    Sep 12, 2014
    Likes Received:
    Hello all,

    I bought a Phantom 2 Vision+ off Amazon about a month ago. Everything worked perfect with it and had almost 40 flights. Found Woot.com was running a deal on them that also came with an extra battery and was cheaper (before the price drop). Asked Amazon if they would work with me on the price since they also own Woot but they said no and I would have to return it. Returned the one to Amazon and received the one from Woot in the same day.

    The issue I have with the new one is in the same place I would fly the old one I was only getting about 5 satellites. Not 100% sure what the old on got but always got a lock and never lost it anywhere I flew it. Tried a different spot and it got 6 but no more and I knew I used to get at least 8 there. Also for a reference, inside my house I would get none with the new one but the old one would at least pull a few. So I installed the foil mod, two pieces of foil sealed in electrical tape is what I used. Only a piece of the wire that goes to the NAZA is exposed (3/4 of an inch max). Put it all together and as pulling up to 9 satellites IN MY HOUSE. Out side I was getting 9-10.

    Then I found the problem, I took off and got to about 150 feet high and only about 300 feet away then I turned on the video recording. The FPV was on this whole time. Once I tuned on the recording it went from 8 satellites to 4 and started to take off in a random direction, switched to ATTI and brought it down and landed it. The problem is, anytime I start recording on the new one I lose at least half of my satellites which almost always makes me lose the GPS lock. I also checked the GPS module and the ceramic on top is intact and not cracked.

    Any ideas? I check the firmware on everything which I updated when I got it. Its all up to date including the camera. I went ahead and re-flashed all the firmware just to make sure. I have done the compass dance and it acts perfectly. As long as I am not recording video, everything works and flies perfectly. The moment I hit record it drops. I can make a video to show it but its quick and happens every time no matter the location. Inside my house it goes from 6-7 on average to 0.
    Nils Erlandsen likes this.
Similar Threads - Vision+ Lose GPS Forum Date
Vision+ remove all the wifi guts Phantom 2 Vision + Mods Oct 4, 2017
P2 Vision+ Battery fault Phantom 2 Vision + Help Jul 19, 2017
The video lag time on my P4P is twice as bad as my P2vision+ Phantom 4 Pro Discussion Jul 15, 2017
Best Log Viewer for Phantom 2 Vision+ and Litchi? Phantom 2 Vision + Discussion May 27, 2017
P2 Vision+ solid red light on gimbal, no live stream, no gps. Please help. Phantom 2 Vision + Help Apr 16, 2017
Thread Status:
Not open for further replies.