Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

x1 channel night mare (gimbal tilt control)

Discussion in 'Phantom 2 Discussion' started by drinkwater08, Mar 16, 2014.

  1. drinkwater08

    Mar 11, 2014
    Likes Received:
    I have had the Phantom 2 for a week now. Just the last 2 days, i have noticed the 7th channel "X1" controlling the gimbal tilt function has got a mind of its own. When using the tilt adjustment it either goes full tilt down or straight forward, i have lost the ability to fine tune the camera tilt. Using the phantom 2 software i can see in the calibration test, that the x1 channel seems to move from 1000 to….. well anywhere it feels like. even when not touching the x1 lever, the tilt seems to creep around, mostly wanting to point the camera straight down.

    anyone have this issue? (yes i have tried calibration)

    Fault in the controller? I have taken it apart to make sure the plastic lever turns the x1 pot, which it does. I have manually turned it with a screw driver, which ends up with the same faulty results. :evil:

    Phantom 2
    TX controller
    Zenmuse H3-2D gimbal (new out of box)
  2. keefer

    Feb 23, 2014
    Likes Received:
    Mine never worked right from the beginning. I was told by a tech that the clearance between the pot and the X1 plastic "post" was not quite long enough to keep good contact with the pot (Phantom 2 Unit with Gimbal purchased in Feb 2014 in the USA). A common fix is to disassemble the X1 lever, pull out the metal shaft and add a small washer (1/16" thick) to it on the flange inside so that it makes solid contact with the pot. The really important part (I found out later!) was in re-calibrating the pot once it had gotten out of position. If you turn the pot gently with a small screwdriver, you find that it will travel 180 degrees and has a definite "center" postion (usually shown with text or writing on it). You will need to find center postion and then turn it so that the text is lined up in the 9:00 position. Put the controller back together without the X1 lever in place (so you can use the screwdriver thru the back). Fire up the remote and the quad and connect it to your computer like you normally would for calibration. Then connect the controller to the RC assistant software (not the Phantom assistant software) and do the X1 calibration by gently rotating the pot thru the hole with the screwdriver back and forth several times. It should make full travel back and forth on the X1 calibration screen. If it makes full travel, you're on the right track! Click finish on the calibration and disconnect from the computer like you normally would. Reassemble the controller with the X1 lever back in place (be sure the pot is set to the 9:00 postion and the "head" of the X1 lever that contacts the pot is lined up with the grooves on the pot before reassembly). Hopefully, you can power everything back up, start PHANTOM assistant software and do the X1 calibration using the lever. This is long-winded but this same thing drove me crazy for 2 days before a tech walked me thru it...I hope this helps out! If you don't feel comfortable with doing this yourself or are worried about voiding your warranty, I would return the unit for service and I'm sure they can correct it for you! I can only say this worked for me. Good Luck! :D
Similar Threads - channel night mare Forum Date
32 channel hack-? Pro/Adv Discussion Wednesday at 11:07 PM
Extra Channel Mod Sill Work on Phantom 4 ? General Discussion Jan 4, 2018
32 Channel Mod for Crystalsky Tablet CrystalSky Monitors Jan 2, 2018
Extended Channels on Crystalsky Tablet General Discussion Jan 2, 2018
Is the 32 channel mod still working? Pro/Adv Discussion Dec 31, 2017