Professional Was this Firmware upgrade successful?

Joined
Feb 8, 2019
Messages
34
Likes
2
Age
52
Location
CT, USA
Website
www.rcpickups.com
#1
Hi all. I'm not exactly sure how to interpret the Dji update log file. At first it says Success but if you scroll down a tiny bit it says Abort then finally it says Failed.
I cant get into the GO app to see what version is installed and if there are any errors until I recieve my new tablet.
Thank you.
Rob.
-------------------------------------------------------------------------------------
Result: Success.

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.05 17:00:45 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.18 14:28:03 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.18 16:00:37 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.08.22 17:40:53 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:02:44 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2019.02.12 12:50:07 =====================
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:01:20 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.
 
Joined
Oct 24, 2018
Messages
637
Likes
342
Age
34
Location
Puerto Rico
#2
Likes: RCP1
Joined
May 19, 2015
Messages
4,162
Likes
2,892
Location
Western US
#3
Hi all. I'm not exactly sure how to interpret the Dji update log file. At first it says Success but if you scroll down a tiny bit it says Abort then finally it says Failed.
I cant get into the GO app to see what version is installed and if there are any errors until I recieve my new tablet.
Thank you.
Rob.
-------------------------------------------------------------------------------------
Result: Success.

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.05 17:00:45 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.18 14:28:03 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.18 16:00:37 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.08.22 17:40:53 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:02:44 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2019.02.12 12:50:07 =====================
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:01:20 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.
To me it looks like you tried to go from 1.2.6 directly to 1.11.20 which could be why it shows so many fails. If you are at 1.2.6 you would normally need to go to 1.3.2 first, and then could install 1.11.20. We usually advise people to follow these instructions which also highlight going to 1.3.2 first.

If you were trying to go to 1.11.20, make sure you understand the changes related to that version. It was released in July 2017 and introduced forced flight restrictions similar to beginner mode if you haven't "registered" your app with DJI. Click here for more info. Also, if you go to 1.11.20 your RC will need to be at 1.6 or higher.

Can you post your LOG_AB file?

FYI, DJI has historically maintained an archive of FW versions on their site even though they don't always show links to them. For archived FW versions directly from DJI, follow the links in this post.
 
Last edited:
Joined
Apr 29, 2016
Messages
3,724
Likes
1,587
Location
Watkinsville, Georgia
#4
This means just what it says....

========== 2014.01.01 00:00:13 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.


Which means that you were trying to update to the same version or older that was already on the aircraft.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

This also means just what it says.

========== 2014.01.01 00:00:15 remo-con disconnect======
Packet: P3X_FW_V01.11.0020.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

You should progress through the updates as opposed to jumping to a current version.
 
Likes: RCP1
Joined
Feb 8, 2019
Messages
34
Likes
2
Age
52
Location
CT, USA
Website
www.rcpickups.com
#5
Can you post your LOG_AB file?
.
I finally got in the app with my neighbors iPhone but it's brand new so things were a bit buggy.
It read:
Dji Go App V3.1.52
AC V1.10.90
TX V 1.2.6
Many thanks to all of you because I cant make heads or tails of these logs.
Rob.
Attached is the LOG-AB file. It's a lot to read through.
 

Attachments

Joined
Apr 29, 2016
Messages
3,724
Likes
1,587
Location
Watkinsville, Georgia
#7
Likes: itbbrian
Joined
May 19, 2015
Messages
4,162
Likes
2,892
Location
Western US
#8
I finally got in the app with my neighbors iPhone but it's brand new so things were a bit buggy.
It read:
Dji Go App V3.1.52
AC V1.10.90
TX V 1.2.6
Many thanks to all of you because I cant make heads or tails of these logs.
Rob.
Attached is the LOG-AB file. It's a lot to read through.
FYI that is not the LOG_AB file. Follow the link in my previous post or this link to see how to get your LOG_AB.

Assuming the versions you posted are accurate, if it were mine I would install 1.3.2 on my RC via the old USB stick method and then follow that up by trying to update my RC (again) via the app. With the AC version you have, you need your RC to be at 1.6 or higher. If you have a 300A RC, you may need to also install 1.4 via the old USB method before then using the app after that point. If you need either version, follow the link in my previous post or this link.

I'd still like to see your LOG_AB file however. ;)

Good luck!
 
Last edited:
Joined
Apr 29, 2016
Messages
3,724
Likes
1,587
Location
Watkinsville, Georgia
#9
FYI that is not the LOG_AB file.
Hmmm....Sure looks like a log AB to me......What do you see out of the ordinary AB?
 
Joined
Apr 29, 2016
Messages
3,724
Likes
1,587
Location
Watkinsville, Georgia
#10
Disregard the above....
 
Joined
Feb 8, 2019
Messages
34
Likes
2
Age
52
Location
CT, USA
Website
www.rcpickups.com
#11
I posted both log files. In my first post it was the main txt file then the attached txt file from the hidden misc folder in my second to last post.
What I'm having trouble understanding and could really use your help on is understanding the information I gathered when I had my neighbors iPhone connected which said I was running:
Dji Go App V3.1.52
AC V1.10.90
TX V 1.2.6

Isn't V01.11.0020 the next consecutive version of FW from v1.10.90?
If V01.11.0020 has limitations I DO NOT want it. The poor distance of my P3 Standard was the reason I bought the P3 ro with Lightbridge.
Is it possible to downgrade the firmware to a version without the distance limitations?

I'm also having an issue linking the TX to the AC. When I got it last week they were linked. Now since trying to upgrade the FW I can't get them to link manually since I don't have my iPad yet (Manual mode=On remote, all at once hold C1, C2 and Video buttons. Power on remote and keep them pressed. Once the remote powers up press inward on the right (shutter speed) wheel. The blue light will come on the TX an the remote will start beeping) When the blue light and beeping start I press the button beside the link LCD for 2 seconds and the AC and TX linkLED's blink red/green for a few seconds but then go back to red. Hopefully this is because I don't have the FW properly installed. I can still roll the gimbal, roll the shutter wheel (beep beep beep)and take videos but the motors wont fire manually as they did when I got it.
I think the first thing I need to do besides having a proper tablet is update the firmware correctly.
Sorry for the long post.
Many thanks for all your help.
Rob.
 
Joined
Apr 29, 2016
Messages
3,724
Likes
1,587
Location
Watkinsville, Georgia
#12
AC V1.10.90
TX V 1.2.6
Someone will correct me if I am mistaken, but if the above is what was shown via the app, 1.10.90 is installed on the aircraft. However, the RC version is not correct and is upgradable from the app only. The old method of updating the RC will not work for this version. If this is indeed true, as I said someone will correct me if I am mistaken, this is most likely why you are having linking issues.
 
Joined
May 19, 2015
Messages
4,162
Likes
2,892
Location
Western US
#13
I posted both log files. In my first post it was the main txt file then the attached txt file from the hidden misc folder in my second to last post.
You haven't yet posted your LOG_AB file as far as I can see. You've posted twice now the routine "result" txt file. Without the LOG_AB file, it's hard for me to trust any version shown.

Isn't V01.11.0020 the next consecutive version of FW from v1.10.90?
If V01.11.0020 has limitations I DO NOT want it. The poor distance of my P3 Standard was the reason I bought the P3 ro with Lightbridge.
Is it possible to downgrade the firmware to a version without the distance limitations?
You shouldn't have any distance limits with 1.11.20 if you do what is shown in the link I gave you earlier wrt 1.11.20.


I'm also having an issue linking the TX to the AC.
I'd assume that this is related to the FW mismatch you listed. As I noted, with the FW you show for your AC your RC needs to be 1.6 or higher.

Without a LOG_AB, its hard to continue with advice.
 
Joined
Feb 8, 2019
Messages
34
Likes
2
Age
52
Location
CT, USA
Website
www.rcpickups.com
#14
Someone will correct me if I am mistaken, but if the above is what was shown via the app, 1.10.90 is installed on the aircraft. However, the RC version is not correct and is upgradable from the app only. The old method of updating the RC will not work for this version. If this is indeed true, as I said someone will correct me if I am mistaken, this is most likely why you are having linking issues.
That sounds very reasonable. I should have my iPad 2 mini tomorrow so I can do this properly.
Thanks very much.
 
Joined
May 19, 2015
Messages
4,162
Likes
2,892
Location
Western US
#15
Someone will correct me if I am mistaken, but if the above is what was shown via the app, 1.10.90 is installed on the aircraft. However, the RC version is not correct and is upgradable from the app only. The old method of updating the RC will not work for this version. If this is indeed true, as I said someone will correct me if I am mistaken, this is most likely why you are having linking issues.
If it is correct, it will only work with the old USB method with the RC. If it's not correct, it's anyone's guess but if it were mine I would start with trying the USB method to update the RC.
 
Joined
Feb 8, 2019
Messages
34
Likes
2
Age
52
Location
CT, USA
Website
www.rcpickups.com
#16
You haven't yet posted your LOG_AB file as far as I can see. You've posted twice now the routine "result" txt file. Without the LOG_AB file, it's hard for me to trust any version shown.


You shouldn't have any distance limits with 1.11.20 if you do what is shown in the link I gave you earlier wrt 1.11.20.



I'd assume that this is related to the FW mismatch you listed. As I noted, with the FW you show for your AC your RC needs to be 1.6 or higher.

Without a LOG_AB, its hard to continue with advice.
Thanks Oso. I thought there were only 2 log files. I can't find any others. I'm sure I'm overlooking something. I'll continue looking
Much appreciated.
Rob.
 
Joined
Apr 29, 2016
Messages
3,724
Likes
1,587
Location
Watkinsville, Georgia
#17
@Oso .....This coming from someone who hasn't updated since 1.8.8... Anyway, if that RC version is correct, I can see why that would only work with the USB method. The RC's as I recall did not start the new app method untill 1.8.8, and from there and above will only update through the app. I just recalled doing the RC through the app with that version and if I am not mistaken, that was the first one through the app. That is why I said what I said about the RC update, since the AC version is apparently 1.10.9, so in theory the USB update should work for the RC.....maybe....
 
Joined
May 19, 2015
Messages
4,162
Likes
2,892
Location
Western US
#18
@Oso .....This coming from someone who hasn't updated since 1.8.8... Anyway, if that RC version is correct, I can see why that would only work with the USB method. The RC's as I recall did not start the new app method untill 1.8.8, and from there and above will only update through the app. I just recalled doing the RC through the app with that version and if I am not mistaken, that was the first one through the app. That is why I said what I said about the RC update, since the AC version is apparently 1.10.9, so in theory the USB update should work for the RC.....maybe....
The last one with the USB method was 1.3.2 for most RCs, 1.4.1 for some 300A RCs. After that, it was the app only for RC updates. My personal 300A required the USB method for both 1.3.2 and 1.4.1, but used the app only after that. All 300B and 300C RCs started using the app with 1.4.1.
 
Joined
May 19, 2015
Messages
4,162
Likes
2,892
Location
Western US
#19
Thanks Oso. I thought there were only 2 log files. I can't find any others. I'm sure I'm overlooking something. I'll continue looking
Much appreciated.
Rob.
If you follow the link I gave you, you'll see that it explains the LOG_AB is probably hidden and you will need to show hidden files. :)
 
Joined
Feb 8, 2019
Messages
34
Likes
2
Age
52
Location
CT, USA
Website
www.rcpickups.com
#20
If you follow the link I gave you, you'll see that it explains the LOG_AB is probably hidden and you will need to show hidden files. :)
Thanks Oso. I always have my hidden folders showing as well as system folders so If it's in the "misc" folder then it's the attachment a few posts up.
I had a friend stop by tonight with his iPhone 6 (I think) The app installed and I got into the app. It said that my RC version 1.2.6 was not compatible with my AC firmware so I suppose that answers the linking problem. But it sent me to download the TX FW right from the app. I downloaded the TX Fw and followed the instructions in the app. The blue light on the TX blinked and beeped for over 40 minutes then I shut it down because I didn't think the TX FW upgrade should take that long. Now it says I need TX v1.3.20 (I currently still have v 1.2.6 ) It no longer asks me to upgrade through the app but it does say to upgrade to v1.3.20 via USB. I downloaded TX v1.3.20 from a link of older firmware generously posted by you but after formatting, extracting the v1.3.20 and plugging the SD card to USB adapter into my TX it would not blink blue or beep at all. I'm pretty confused.
I really appreciate all the help you guys are offering.
If you have any idea what I'm doing wrong please don't be afraid to shout at me. I'm sure I deserve it. ; )
Thanks.
Rob.
*EDIT* My RC IS A GL300A model if that makes any difference
 
Last edited:

New Threads

Forum statistics

Threads
132,351
Messages
1,371,973
Members
96,638
Latest member
Mahoney.Julia