Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Upgrading to v3.16 from a noobs perspective

Discussion in 'Phantom 1 Help' started by UTR, Sep 1, 2013.

  1. UTR


    Aug 20, 2013
    Likes Received:
    I have only had a Phantom two weeks or so and v3.16 was my first upgrade and I think I made every noob mistake going below are extracts from my blog about the errors I encountered and what I discovered them to be and how I fixed them. At first I thought that there was a lot wrong with 3.16 as it turns out I just didn't know what I was doing. My Phantom is now on 3.16 and everything works perfectly again. If you read through all the way you might find the answer to any issues you have with 3.16. They are however written as I discovered the answers so you have a bit to read :D

    Sunday 25th August 2013

    Naza-M Firmware v3.16

    Hi everyone I have been reading the forums and looking at lots of info online and a lot of people have recommended that I upgrade the firmware in my Phantom so today I am going to do a short video on how to do this. Before you begin you need to download a few files from the Phantom support section on DJI’s website. The files you need to download are the Naza-M Assistant Software v2.16, the DJI Driver installer and just to be on the safe side the Phantom Default Configuration Parameters. I won’t link to these files directly as they may be upgraded over time you should always check their website for the latest info. With any firmware updates DJI produce release notes that tell you what’s new in each revision as of yet I have never plugged my Phantom into my PC so I don’t know what version of the firmware I am running. If you’re Phantom is running correctly and you don’t need or want the changes in the release notes then my advice is to only upgraded when you need it. Looking through the release notes there have been a number of small fixes, optimizations and additions over the last two or three versions so I will install the software and check which version I am running and upgrade to the latest version.

    As with all thing SAFTEY must come first before doing anything I have REMOVED THE PROPS from my Phantom. If the programming should fail for any reason the last thing I want is the props spinning up out of control. Better to be safe than sorry.

    After recording several videos I have had a mishap on my PC and lost them all I am attempting to recover them now if I can I will post them if not I might re-record them. I couldn’t recover the videos so I have recorded the process again here.

    Ok so the firmware upgrade didn’t quite go to plan. I downloaded the Naza-M Assistant Software and the DJI Driver and installed them onto my PC. I then turned on my Phantom and it failed to install the driver? OK Weird so I turned the Phantom off again and uninstalled the driver. I then turned the Phantom back on and ran the driver program with the Phantom already connected to my PC and this time the driver detected the Phantom and installed a 64bit version of the driver which then worked perfectly.


    Opening up the Assistant Software it immediately presents a pop-up saying that there is an upgrade available and a second popup saying ERROR[27] message the compass was not calibrated (as I was in the house I fully expected this and planned on doing a compass recalibration once the firmware was updated).

    A quick check confirmed I was running 3.14 and 3.16 is available so I clicked on the upgrade button. My Phantom flashed its status light made a few beeps and in no time at all had taken the new program I did however get an error message about transmitter calibration which I loosely skipped over. Great I thought that was easy. I then took my Phantom outside and powered it up transmitter first then the Phantom. Sure enough I got the red and yellow flashing lights indicating that the compass was out of calibration so to enter calibration mode I flicked the GPS/ATT switch 10 times and nothing happened?? OK I thought I wonder what’s going on here so I tried it again and a second time nothing happened. I quickly jumped on google and sure enough the red/yellow flashes were the compass. I then remembered the transmitter error message that I had skipped over luckily as I was recording video I could go back and read what it said and the message read -


    That will teach me to skip through things anyway I thought ah I haven’t power cycled my transmitter only my Phantom so I turned my Tx off and on again and then restarted the Phantom only to have exactly the same error? I then did another google search and came across a part of the wiki that says that if you ever change transmitters or lose connection that inside the Phantom is a reset link button OK I thought if I have to I’ll open her up then I will. Just before I did I decided to read a couple more posts and I’m glad I did because just below was the correct answer (almost). For some unknown reason (I have since discovered why later read on) when you connect your Phantom to the Naza-M software the receiver type defaults to D-Bus the stock Phantom receiver type is PPM. Plugging my Phantom back into my computer I loaded up the software and sure enough my Rx was set to D-Bus I changed this to PPM, unplugged my Phantom went outside and sure enough then transmitter worked and I was able to enter compass calibration mode.

    I was stood by the side of the house and I don’t normally fly here as there’s not much space but I thought a quick test flight would be fine. I powered up the Phantom and took off (it felt a little sluggish) as I got to roughly the height of the roof the wind picked up and caught the Phantom so I put it full speed into the wind but too late it went clattering into the Chimney and ended up crashing upside down on the roof of my neighbours extension. A quick look with a ladder and broom handle and I recovered the Phantom (Woohoo! my first crash). Upon checking the Phantom over I have broken one of the prop guards as can be seen below this isn’t an issue some superglue will soon have it mended and I’ve grazed a couple of the props again not really an issue.

    I then thought I would take it over the park and test the new firmware. I was a bit breezy and the Phantom seemed again sluggish at take-off, it also struggled to keep its position in the wind and it seemed to be leaning and very wobbly. The throttle didn’t seem particularly responsive. Is there something up with the 3.16 firmware? (As it turns out no v3.16 is fine) but again I went back to google I went to see if anyone else had had a similar issue and I can across a link to the wiki and a section on calibrating your Tx. Also it might mean that the IMU may need calibrating but when connected to my PC it indicated that it was fine. I will recharge my batteries, calibrate my Tx and quickly go for another test flight.

    Calibrating your Tx

    Below I have quickly reworked the instructions for calibrating the Tx as it took me a couple of goes to get it to work.

    1. Set the switch S2 at the OFF position, and the switch S1 at the GPS position
    2. Push the Throttle stick to the top position, and push the Pitch stick to the top position. Keep the Pitch stick at the top position manually since it can return to the central position when released. (On my controller both joysticks are sprung loaded so you have to hold both sticks fully up).
    3. Turn on the Power Switch of the transmitter, you should hear the indicator sound of “Di—Di Di” from the transmitter repeatedly.
    4. Toggle the switch S2 to the CL position, you should hear an indicator sound of “Di” from the transmitter, in this case, the transmitter has entered the calibration mode.
    5. Release the Pitch stick and pull the Throttle stick to the central position. Or as with my Tx just release it.
    6. Toggle the switch S1 to the bottom ATTI position (not the middle one), you should hear an indicator sound of “Di” from the transmitter.
    7. Then move all of the sticks throughout their complete range several times.
    8. After this, put the Throttle stick to the bottom position, and toggle the switch S2 to the HL position, you should hear an indicator sound of “Di” from the transmitter, in this case, the transmitter has been calibrated successfully.
    The Tx lights will flash a few times then go to solid red meaning all is well. (note to self - record a video of this when the go-pro arrives).

    ERROR[27] and No IOC

    I have just fully charged my 2nd battery and I have given 3.16 another flight test over the park and the take is definitely sluggish I give it full throttle and it just sits there for a second before slowly lifting off nothing like 3.14. I’m going to double check the default parameters.

    OK well that seems to of been entirely my fault I didn’t load the default parameters back into the Phantom as soon as I had you can see that most of the gain settings are 25% higher than the default now at 125% and the vertical gain went from 50% to 100%. Just a note as soon as I plugged in my Phantom I got Error[27] about the GPS again don’t panic just go outside and recalibrate. It’s also worth noting that without the GPS being calibrated the software seems to have IOC disabled not off but DISABLED so just be aware that you may need to re-enable IOC after calibrating your GPS and before you fly next time. To do this just plug it back into your PC click on the “Advanced” button then the IOC button then just tick the check box in the top left hand corner.

    The sluggish response is clearly down to a PEBKAC error. I won’t have time to test it today but I’m confident that it will be fine tomorrow. I’ll test it in the morning and update you before I got to work.

    PEBKAC = Problem Exists Between Keyboard And Chair

    It looks as though all the issues I have had upgrading are entirely down to me and almost everything seems to be working perfectly now I hope this helps it has definitely been a learning curve for me today. The only thing I have noticed it that my Phantom is still sluggish during take-off and the back end drops (if I didn’t have prop guards the rear props would hit the ground). Once airborne thought the Phantom seems to fly properly. This might be an IMU calibration issue even though the assistant software tells me it’s correctly calibrated. I will have to investigate further.

    Friday 30th August 2013

    Hi all, well I’ve spent another day sat at home ill today so I thought I would try and calibrate the IMU just in case it was the cause of my Phantoms underpowered take—offs. I charged all my batteries went outside plugged my laptop into the Phantom and powered it up, I then loaded the Naza software assistant clicked on the Tools menu, then the advanced tab and then clicked on advanced cali at which point I was greeted with a warning message about the MC being over temperature and to turn off the system and allow it to cool down. Hmmm since I had only just turned it on for the first time today that was weird. The error is also not cancellable, once it’s on the screen the only way to get rid of it is to unplug your Phantom and close the software. I reconnected everything and thought I would try again and again I got the same warning. A quick google search provided me with loads of threads about people having the same warning. I kept clicking on the retry button and eventually the IMU calibration started. It said on the screen that it may take 5-10 mins but on my machine it was more like 10 seconds. OK I thought maybe that didn’t work so I tried it again and again I had to click retry about 30 times to get passed the MC over temp warning. Eventually it started the calibration but again only took about 10 seconds (and yes I am definitely on advanced and not basic). I then popped the battery in properly, recalibrated the compass and tried a take-off and sure enough my Phantom is back now taking off level which is great. It still feels a little slower than v3.14 but then again that might just be me. I have to say that there are a number of pitfalls to look out for when upgrading the firmware but now I have done it once I know what they are. Upgrade the firmware, load the default config file, recalibrate the IMU then recalibrate the compass and all should be good. I will go for my first flight later with my GoPro attached which I’m really looking forward too I’ll post the video later, TTFN 

    Well I took the Phantom out for a night flght I’ll skip the video as I didn’t put the Hero in night mode and all you can see is the occasional light whizz by I’ll get some daytime shots tomorrow.

    Saturday 31st August 2013

    Hello fellow flight fans well today I upped the gain on my Phantom on the vertical setting to 125% and it seemed to take off better I will try again tomorrow on 150%. I shot some video on the GoPro I have stuck the flat adhesive mount on the Phantom and then used the clip off the underwater mount attached to the Phantom bracket from DJI. The video is a bit all over and there’s not too much ‘Jello’ in the shots considering that there no suppression and my props are not only not balanced but after my crash the other day they’re looking a bit worse for wear. I think with a set of balanced props I’d have almost not jello. That being said I have ordered some parts of eBay to make a more stable mount maybe even a gimbal. I’ll upload the video later for you to check out.
  2. Roadkilt

    Mar 25, 2013
    Likes Received:
    Why did your write all this?
  3. UTR


    Aug 20, 2013
    Likes Received:
    A lot of people were reporting issues with 3.16 a lot of which I experienced which turned out to be just me not understanding what I was doing wrong. I wrote this as a diary on one of my blogs and just copied it here since I managed to resolve every issue I had with 3.16. I thought it might help other people in sorting out their setup issues after the upgrade.
  4. FangsCPO

    Apr 7, 2013
    Likes Received:
    Chula Vista, CA
    Wow!! That is alot of info. I understand what your intent was but it's just too wordy. So ultimately, your take-offs were concerning to you because they were too slow. Are you flying the Phantom stock or did you add a GoPro and gimbal into the mix. I would also recommend upgrading your props to carbon fibor props. Good Luck!!
  5. UTR


    Aug 20, 2013
    Likes Received:
    It turned out to be just the vertical gain needed to be set higher. It's fine now :) I just cut it from my blog I should of edited really :)
Similar Threads - Upgrading noobs perspective Forum Date
Rebuilding/Upgrading a Phantom 3 Standard. Standard/4k Discussion Friday at 4:28 PM
P3P onwers - think twice before upgrading firmware Pro/Adv Discussion Jul 13, 2017
Professional Upgrading P3P after over a year of no use Phantom 3 Help Jul 9, 2017
Trade no longer required - Anyone with a P4P controller interested in upgrading? Classifieds Jul 4, 2017
Thinking of upgrading from Phantom 4 Phantom 4 Pro Discussion Jul 2, 2017