Totaled my phantom 3 in a crash this morning

Joined
Jan 19, 2014
Messages
56
Reaction score
22
20 seconds into my flight this morning my phantom crashed to the ground. Not straight to the ground but at an angle. From reading the forums I think I can access my flight data. How do I do that and what am I looking for to see if it's my fault ( and I understand it probably is) or if it's a glitch of some kind.
 
Joined
Aug 29, 2014
Messages
489
Reaction score
130
I thought fatal meant you killed someone.
 
  • Like
Reactions: Ches and acherman
Joined
Mar 22, 2014
Messages
596
Reaction score
161
Location
Illinois
Open the app and select "user center" then select the icon that looks like an arrow in the center. Post it here so we can help ya figure out what happened.
 

ianwood

Taco Wrangler
Joined
Jan 7, 2014
Messages
5,109
Reaction score
2,043
Location
Lost Angeles
Post up whatever you have. Data, video, etc. Consider rephrasing to "totaled" instead of "fatal". There are plenty of instructions on this site for accessing the data files.
 
Joined
Apr 10, 2015
Messages
2,248
Reaction score
460
Location
Virginia
One question. Before you took to the air did you do the IMU calibration, RC stick calibration and when ready to fly the compass calibration. If the answer is no to any of these..... Ops!!!!! Fix it and do it. Very important.
 
Joined
Dec 30, 2014
Messages
146
Reaction score
60
Location
Long Island, NY
Oh, so you had one of them "fatal" crashes I read about. You should consider changing the thread title to reflect the seriousness of the crash. Maybe "fatal" instead of "totaled". :rolleyes:
 
Joined
Jan 19, 2014
Messages
56
Reaction score
22
ImageUploadedByPhantomPilots1433876756.081216.jpg
 
Joined
Apr 13, 2015
Messages
1,044
Reaction score
388
Location
Tim in San Diego
I'm extremely sorry I even mentioned this. I thought I'd get some help not vocabulary lessons

Calm down.. You said the photo was the wrong one? As that just showed a damper came undone...easy fix... Is that the damage? I looked again that's all I can see...took mine off the other day and washed them. Try and pop the gimble in easy and then the damper...then fire it up without props. Did the cable break?
 
Last edited:

New Threads

Members online

Forum statistics

Threads
140,635
Messages
1,449,471
Members
102,438
Latest member
safeharbour