Thoughts or suggestions needed

Joined
Jan 12, 2021
Messages
59
Reaction score
19
Age
57
I have a Phantom 4 Pro+ V2. It was put together and not bought as a unit. Everything works on it (no yaw drift!) except it has one quirk I'd like to fix. The controller will not link to the drone until I let the drone "warm up" for about 2 minutes and then power cycle it. After that it connects and stays connected. No issues at all after that. I believe it's the drone, not the controller as the controller can be on or off or power cycled and it still will not connect to the drone. Only when the drone has been power cycled after the "warm up" period will the controller connect. I'm not sure what part/board in the drone is responsible for the connection. Main board? If anyone has had this issue and was able to fix it I'd like to hear how you did it. Anyone that has some suggestions, I'm all ears.

Thanks,

Roger
 

ianzone

**P4**
Joined
May 22, 2016
Messages
7,333
Reaction score
4,970
Age
52
Location
NZ
In the past a good tip was to chill the drone and do imu calibration, that way when powered up the imu warm up time was shorter,,even myself did this,,stick it in da fridge to drop temperature of drone components, that way in real air temp it should be ready to fly sooner,,,yeh I know it sounds crazy but did work for a lot of flyers,,give it a try
 
Joined
Jan 12, 2021
Messages
59
Reaction score
19
Age
57
I did this back in the winter here. Had it out in the cold garage overnight. Didn't make a difference. But, at this point, willing to give it a try again.
 
Joined
Feb 3, 2018
Messages
976
Reaction score
727
Age
59
Location
Albuquerque, New Mexico
I would check the firmware on both the controller and drone and maybe reinstall it. It's possible that a module got screwed up, which explains why you are able to reproduce the problem so reliably. I would start with the controller. Reinstalling controller firmware is painless and free, so no reason to not try it.

D
 
Joined
Jan 12, 2021
Messages
59
Reaction score
19
Age
57
Thank you for your suggestion. I checked the drone firmware this morning. I did notice that when it was connected that it showed the option as Upgrade instead of Refresh. I did the Upgrade and it successfully installed and now shows as Refresh. The upgrade process seemed different than what I remember as well. I am letting it cool down and see if this corrected the quirk. Definitely something different than before. Fingers crossed.
 
Joined
Jan 12, 2021
Messages
59
Reaction score
19
Age
57
Well, it did not completely fix the problem, but it cut the wait time considerably. Instead of about 2 minutes of warming up to about 15 seconds now. That was the first time tonight as a test. I'll have to see in a few days after it sits for a while.
 
  • Like
Reactions: ianzone
Joined
Jan 12, 2021
Messages
59
Reaction score
19
Age
57
After letting it cool down overnight, it appears to not have made any difference. Still takes about 2 minutes to warm up, then a power cycle and it connects to the controller.

I don't think this has anything to do with the IMU cold calibration as that I believe just speeds up the ready to fly time. Has nothing to do with the initial link connection. I still think it has to do with the main 3 in 1 board as the link is part of its responsibilities. I just don't want to fork out the cash for one to see.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
141,973
Messages
1,459,704
Members
103,748
Latest member
Christinag