Switching from way-point mission gps to atti mode

Joined
Oct 14, 2016
Messages
12
Reaction score
3
Age
80
Hi
I would love to know the reason for this episode during a Litchi mission when my Phantom 3 Advanced suddenly reverted to atti mode while flying a way-point mission. It then quickly switched between atti and gps-atti several times and from then on ignored the subsequent 7 way-points. I had at least 14 satellites in view at all times, and the compass was OK since it flew directly home when I instigated RTH. I had previously flown the route at a constant 80 metre altitude with no problems. I've attached the csv file in text format. and here are links to visualisations

http://www.flightreplay.com/share/track/ignored-flight-plan
HealthyDrones.com - Innovative flight data analysis that matters
Phantom Log Viewer - PhantomHelp.com

A screen capture of the original mission flight plan is also attached.
If anyone out there could suggest what went wrong with this flight I would be very grateful, because if this had happened when out of control range I could easily have lost the AC.
 

Attachments

Last edited:
Joined
Nov 4, 2016
Messages
244
Reaction score
88
Age
44
Funny you mentioned this, I had the exact thing happen to me today I had screen recorder going so I'm working on cutting it to a decent size and gonna upload to here. Mine did same thing for no reason it switched to atti and then to GPS and just hovered there, on screen it said it was moving to next waypoint but speed 0 mph as it was just hovering in GPS mode. Very unsettling if this was to happen during a signal loss distance wp and it's just hovering draining the battery while you think it's continuing the mission. Naughty litchi they better get this squared away it's pretty dangerous
 
Joined
Nov 4, 2016
Messages
244
Reaction score
88
Age
44
This has the vid of the screen recording when it happened to me, not sure if it's what happened to you but it sure sounds similar.

Warning for litchi users
 
Joined
Oct 14, 2016
Messages
12
Reaction score
3
Age
80
Yes, it does sound very similar, but what is the reason? I do hope someone can suggest something because it is worrying. Is it a hardware or software bug?
Or maybe there is some sort of interference causing loss of GPS signal, although there is no sign of that in the log.
 
Joined
Nov 4, 2016
Messages
244
Reaction score
88
Age
44
Yeah I hear that, I would definitely like to know too, kinda scary lol hopefully one of the pros knows and can put us litchi users minds at ease :)
 

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
13,980
Reaction score
7,996
There has been some bad solar storms in the past couple days. Maybe that interfered somehow?
At worst, the only effect solar storms would have would be to give the GPS a position error a couple of feet larger.
If this happened, you'd never even notice.
Whatever the issue is, it has nothing to do with solar storms.
 
Joined
Aug 15, 2016
Messages
3,592
Reaction score
1,539
Age
39
I keep getting something similar flying. Switches to ATTI mode and GPRS mode despite having 18 satellites using litchi. Always comes back tho. Done a mission and it said "navi" what the hell is that ? Lol

Sent from my HUAWEI LYO-L01 using PhantomPilots mobile app
 
Joined
Oct 14, 2016
Messages
12
Reaction score
3
Age
80
I cannot judge whether solar storms could disrupt the GPS signal. However it that was possible, I think that we would be hearing a lot more about it in the press considering how much modern navigation depends on GPS.
Anyway it does seem that this problem is fairly common.
Does anyone else have any suggestions, as I am still worried about flying long way-point missions with this bug.
 
Joined
Oct 14, 2016
Messages
12
Reaction score
3
Age
80
I've had a quick search through the forums for the last few months and this subject has come up several times. There have been no definitive suggestions as to the cause of the problem.
It does not appear to be due to compass miscalibration or loss of GPS signal, nor to the effect of magnetic or electromagnetic interference. There are plenty of videos of Litchi way-point missions in cities, with all the potential sources of interference such as steel re-enforced buildings, power lines, railways, ships, radio stations, etc, that have completed successfully. At the same time we have all these stories of the dreaded random switching to ATTI mode during Litchi way-point missions in open country, which happened to me. So I also have come to the conclusion that it is a software bug in Lichi, or some sort of incompatibility between Litchi and the RC. In future there is no way that I am going to fly Litchi way-point missions that take the AC out of RC range, so that I can always RTH when or if one of these worrying episodes occurs.
 
  • Like
Reactions: GhostRdrTat
Joined
Mar 10, 2016
Messages
322
Reaction score
83
I have nearly 400 flights and over 300 miles of flight on my 1 year old P3P. I am running the latest firmware on it. Recently I experienced issues with the gimbal roll control. There were occasions of roll vibration. I found that the position sensor on the roll control board is starting to wear out. So I bought a replacement roll control board which I replaced yesterday. I recalibrate the gimbal and all looked ok on my desk. Later I took it out for a flight where I almost crashed it. During that flight, the AC went in and out of ATTI mode randomly. Throughout the flight I had 17 Sats and NO compass problems, yet it randomly switched to ATTI mode. Since it was windy with lots of obstacles I almost lost the drone. This random switching NEVER happened to me before and I sure was surprised apparently loosing control. Cut the mission short and worked through some troubleshooting. After a complete IMU and Gimbal recalibration and all other checks I took it back out. This time everything was picture perfect. Replacing a gimbal control board without IMU recalibration could have caused this problem?

Here is the link to that flight: HealthyDrones.com - Innovative flight data analysis that matters
 
Last edited:

New Threads

Forum statistics

Threads
136,714
Messages
1,413,702
Members
99,379
Latest member
rbieri