Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

STILL Screwing around with the RC Firmware!

Discussion in 'Pro/Adv Discussion' started by ecarfar, Aug 18, 2015.

  1. ecarfar

    Jul 23, 2015
    Likes Received:
    Bellport, New York
    So I was initially using a Nexus 7 II tablet when I received the P3 a few weeks ago. As soon as I tried to update my RC to 1.3.20 I began to get error messages to update my firmware even though the app was telling me I had 1.3.20 installed.....I got tired of messing around with the apparent mismatch and decided to just invest in an Apple iPad Mini 2. As soon as I matched up the iPad with the RC I checked the firmware version and it says "unknown"! So, just for kicks...I reattached my Nexus 7 II and now, instead of giving me the error to update the firmware it says I'm running 1.3.20+! I can't figure this out. I feel safer flying with the Nexus tablet instead of the iPad. Any ideas on how to get the iPad to recognize the firmware on the RC?????
Similar Threads - STILL Screwing around Forum Date
The Litchi app: Anyone had or still has it? For how long and do you have any remarks about using it? Control (Go, Litchi, etc..) Wednesday at 5:02 PM
Phantom 4 still under warranty Classifieds Aug 9, 2017
P3 Standard still image quality Standard/4k Discussion Aug 6, 2017
Even after today's firmware update, still no maps on P4P+ Phantom 4 Pro Discussion Aug 4, 2017
Even after today's firmware update, still no maps on P4P+ Phantom 4 Pro Help Aug 4, 2017