Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Rx stock board on Phantom 1

Discussion in 'Phantom 1 Help' started by twist4, Feb 23, 2014.

  1. twist4

    Jan 24, 2014
    Likes Received:
    Stock Rx - Phantom.older

    I just got one. And they said it was an older version, 1.1.

    So, I was able to upgrade the Naza-M to 4.02. And all seems fine in the assistant, can test the motors, etc.

    But, I didn't get the transmitter. I have a Dx6i. I put in a new OrangeRx 620 and it will bind. But, when I connected to the Naza, both as S.bus and traditional. separate power or not, it would not respond. I pulled it and it is still bound and works servos, but not attached to the Naza-M.

    So, being a professional troubleshooter for a big computer company, I ran all the combos I could think of and nothing.

    Fine. I wanted the Futaba 8gfs, anyway. I got that. Put back in the stock Rx and no matter what, it will not bind to the Futaba. I got the radio setup first, and all the failsafe, atti, GPS switches, etc, set. Nothing. I down rev the firmware, nothing,

    I do every trick and combo, nothing. I looked all over here and the web, and even tried it with the transmitter in Mode 1.

    So, my question is, does anyone know of incompatibility issues with that old stock receiver? The main LED flashes Amber, of course, on the ship. No transmitter found.

    But, when I press the link button on the Rx, the little light flashes a yellow-red, and never binds.


    Realize please, I am not taking about the main ship LED. And I am not talking about the red-yellow flashing of the main LED.

    I was aware of the need to change the Rx type in Assstant, and did change it. I was trying the s.bus as well as the traditional on the 620.

    The stock Rx is suppose to be a Futaba FASST Rx.

    And I have tried all the combos and all the videos, but no one mentions the red/yellow, both colors at once, blinking on the Rx.

    I wonder what that error state is?. I wonder if there is a known incompatibility?

    Since I can't link to the transmitter, I can't run the switch back and forth 10 times to get in into that compass mode.

    Do you know a way to do it, in Assistant?

    The V1.1 Flowchart says, if the ship is flashing quick amber, it is in failsafe and has no link to the Tx.

    I get that LED, but, I mean the tiny light on the Rx board. It is changed from red to bind to the Tx, by pushing the micro-switch. It is supposed to be flashing red, but mine is flashing a -yellowish-red.

    And bind success means no red light. I always get the red light again. The throttle sick does nothing.


    Sep 5, 2013
    Likes Received:
    N 44.895 W 93.354 Minnesota
    The original Phantoms were PPM and oe Rx will not bind with anything but oe Tx. If you're going to use Futaba you have to get their Rx.
  3. twist4

    Jan 24, 2014
    Likes Received:
    Thanks, I was made aware of that. So, I did install a Futaba R6208SB.

    So, that is behind me now. But, the worse is, it won't start. Everything looks good to go, in Assistant. TX is calibrated. Assistant is calibrated to TX. All the Failsafe, Modes and Courses, can be selected and show correctly.

    It just will not take any of the CSC to start.

    Does anyone know a setting for the throttle in 8fgs that will force a start?

    Right now, the slider on the Assistant for throttle, runs left to right, -1000 - +1000.

    So, 50% throttle is Zero in Assistant. Can that be right?
  4. twist4

    Jan 24, 2014
    Likes Received:
    I post details in my Won't Start thread.

    It turned out it was the deguassing of the compass with a magnet that did it. BPut the procedure is a little obscure.

    I tried to explain it better in the other thread.
Similar Threads - stock board Phantom Forum Date
Hdmi board UK stock Pro/Adv Discussion Aug 1, 2015
7.85 High Brightness in stock CrystalSky Monitors Wednesday at 8:05 AM
DJI Goggles in Stock with Free Shipping DJI Goggles Jul 14, 2017
Standard Reason Why Stock P3S Has Such Poor Range Phantom 3 Help Jun 15, 2017
DJI Goggles in Stock! DJI Goggles Jun 11, 2017