Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Rotors won't start

Discussion in 'Phantom 2 Vision + Help' started by RaymondElvis, Dec 13, 2014.

  1. RaymondElvis

    Dec 12, 2014
    Likes Received:
    Hello again everybody.

    Fresh off of my last camera tilt problem, which was resolved with several X1 calibrations, I have a new problem. Again, I have a Phantom 2 Vision Plus v. 3.0. It has yet to be flown. After all initial tests worked at home, when I went to the field and performed CSC, the rotors would not start. I moved locations, and they still don't start. They also now won't start in my home. I am not in a no fly area, but am in a restricted area. I tried calibrating the sticks on the Assistant and Remote Control programs. I calibrated X1 again and did a basic and advanced IMU calibration and nothing. The battery is fully charged and the compass was calibrated. When in the field, the Vision's lights, after calibration were blinking green with red flashes to let me know I was in a restricted area. I reinstalled various firmware as well. Again, it has never been off the ground, so there is no issue with trauma or damage to the Vision.

    Additionally, the gimbal moves slightly when I perform CSC, and the X1 calibration is set to "Rev," but I am not sure what that means.

    I thank you all in advance for any help.

Similar Threads - Rotors won't start Forum Date
Quick yellow flashing lights on Phantom 2. Rotors won't start. Phantom 2 Help Jul 23, 2015
how to clear sand when can not even rotate rotors Pro/Adv Discussion Jun 15, 2017
Silent Rotors / Props Phantom 4 Pro Help Jun 15, 2017
Looking for Phantom 1 non-self-tightening rotors Classifieds Apr 1, 2017
Phantoms (and other multirotors) louder at higher altitudes? General Discussion Sep 6, 2016