Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Ribbon Install

Discussion in 'Phantom 3 Help' started by Ghost Rider, Apr 29, 2016.

  1. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I installed a new ribbon. The camera won't do anything. What gives? I've checked all he plugs. I can hear the two gimble motors buzz when I turn the motors when the Phantom is powered on. All three motors are getting power. The camera is warm so that board is getting power.
     
  2. Ghost Rider

    Joined:
    Apr 5, 2016
    Messages:
    319
    Likes Received:
    88
    I guess nobody fixes the gimbles when the camera snaps off.
     
  3. GaryDZ

    Joined:
    Sep 14, 2014
    Messages:
    172
    Likes Received:
    37
    Location:
    Shelton,CT USA
    Found this:

    You probably did everything ok. It might be something else.
     
    #3 GaryDZ, Apr 30, 2016
    Last edited: Apr 30, 2016
Loading...
Similar Threads - Ribbon Install Forum Date
Installed new ribbon, but camera not moving p3a General Discussion Jul 10, 2016
Installed new ribbon but camera doesn't work Standard/4k Discussion Apr 29, 2016
Installed gimbal ribbon protector ??? Pro/Adv Discussion Jan 31, 2016
Video and Camera operate but no movement after Yaw arm and ribbon replacement Standard/4k Discussion Yesterday at 9:43 PM
Limp gimbal after ribbon replaced..... Standard/4k Discussion Yesterday at 4:51 PM