RC led power yellow

Joined
Nov 28, 2016
Messages
6
Reaction score
0
Location
France
Hi,

I have a problem with my remote controller (NDJ6) after upgrading firmware, the power led switch to yellow.
I tested to calibrate my controller but color not change to green like before upgrade…

With this problem, I can't controlle my Phantom 2… :/

How to do ?

(same problem:)
 
Last edited:
Joined
Oct 12, 2014
Messages
5,136
Reaction score
572
Location
Commerce Twp,MI
Hi,

I have a problem with my remote controller (NDJ6) after upgrading firmware, the power led switch to yellow.
I tested to calibrate my controller but color not change to green like before upgrade…

With this problem, I can't controlle my Phantom 2… :/

How to do ?

(same problem:)
That video is not of an NDJ6 which is the newer of the remotes used by the P2.
 
Joined
Oct 12, 2014
Messages
5,136
Reaction score
572
Location
Commerce Twp,MI
If you have an NDJ6 remote have you charged the battery? An if the remote is the older DJ6 have you replaced the AA batteries?
 
Last edited:
Joined
Nov 28, 2016
Messages
6
Reaction score
0
Location
France
On the video its an older controller, I have the NDJ6. The battery is charging, but it can't start the motors…
The power led is yellow/orange and the 4 others led is green.

 
Last edited:
Joined
Oct 12, 2014
Messages
5,136
Reaction score
572
Location
Commerce Twp,MI
On the video its an older controller, I have the NDJ6. The battery is charging, but it can't start the motors…
There are three reasons for that problem.

1) the remote is not paired to the P2.

2) If the spring loaded info pins do not contact the copper pads on the battery the motors will not start.

3) If the GPS cable comes loose and not good contact with the socket the motors will not start.
 
Joined
Nov 28, 2016
Messages
6
Reaction score
0
Location
France
There are three reasons for that problem.

1) the remote is not paired to the P2.

2) If the spring loaded info pins do not contact the copper pads on the battery the motors will not start.

3) If the GPS cable comes loose and not good contact with the socket the motors will not start.

1. The remote is paired to the P2, le led under the P2 is green.

2. Switch to an other battery and same problem.

3. The P2 is ready to fly, the led of the P2 is green.

It's just the remote, before upgrade it was ok, but not now. The upgrade crash the first time, I updated in loader mode and the remote is in yellow led mode now…
With the P2 is power off, the led is yellow on the remote.

I checked on the web, I don't find the solution :(
 
Joined
Oct 12, 2014
Messages
5,136
Reaction score
572
Location
Commerce Twp,MI
1. The remote is paired to the P2, le led under the P2 is green.

2. Switch to an other battery and same problem.

3. The P2 is ready to fly, the led of the P2 is green.

It's just the remote, before upgrade it was ok, but not now. The upgrade crash the first time, I updated in loader mode and the remote is in yellow led mode now…
With the P2 is power off, the led is yellow on the remote.

I checked on the web, I don't find the solution :(
Maybe I wasn't clear In # 2&3.

Changing batteries on the P2 isn't going solve the problem of not being able to start the motors if the information pins, which are spring loaded, do not make contact with the copper pads on the battery or if those pads are dirty.

Now if the GPS cable inside the P2 comes either loose or completely disconnected the motors will not start no matter whether you have green LED's on the rear two arms of the P2.

So check info pins ,batteries copper pads and last of all open the shell of the P2 an check the GPS cable.
 
Joined
Nov 28, 2016
Messages
6
Reaction score
0
Location
France
The GPS cable is ok, I checked the cable connexion and P2 green blinking read to flying.
The P2 is new, just 1 fly without gimbal, after installed gimbal on the P2 is ok, blinking green. Updated the remote, crash update and problem…
What is the yellow power led color on the remote ? I don't understand why I can't fix this problem.

Edit: I updated and calibrate my RC again, the led is green !
But I can't start motors…
 
Last edited:
Joined
Oct 12, 2014
Messages
5,136
Reaction score
572
Location
Commerce Twp,MI
The GPS cable is ok, I checked the cable connexion and P2 green blinking read to flying.
The P2 is new, just 1 fly without gimbal, after installed gimbal on the P2 is ok, blinking green. Updated the remote, crash update and problem…
What is the yellow power led color on the remote ? I don't understand why I can't fix this problem.

Edit: I updated and calibrate my RC again, the led is green !
But I can't start motors…
Have you opened up the shell of the P2 to check if the GPS cable is still plugged in into its socket?? If not after the crash you had it may come loose or disconnected from its socket and can be the cause of the motors not starting up.
 
Joined
Nov 28, 2016
Messages
6
Reaction score
0
Location
France
Yes, my P2 is open, I checked the socket I looked if it is not connected upside down, but its impossible to bad connect. When I closed the top of P2, cable don't move. The problem come from elsewhere ?
 
Joined
Oct 12, 2014
Messages
5,136
Reaction score
572
Location
Commerce Twp,MI
Yes, my P2 is open, I checked the socket I looked if it is not connected upside down, but its impossible to bad connect. When I closed the top of P2, cable don't move. The problem come from elsewhere ?
Ok. Had you checked the spring loaded information pins in the battery compartment right under battery power terminals to see if there are broken. If either of those two pins do not make contact with the copper pads on the battery those motors will not start.
 
Joined
Nov 28, 2016
Messages
6
Reaction score
0
Location
France
Ok, I tested that. I checked my 2 batteries and the P2 connectors. In my RC the motors start in ATTI mode, but not in GPS. I removed the battery, checked again, and miracle the motors start ! I don't understand why, but for test the good running I flying during 5-10min and It was ok…
Thank you very much for help me :)
 
Phantom Drones from EALLRC.com

New Threads

Forum statistics

Threads
136,764
Messages
1,414,151
Members
99,404
Latest member
Skwerl