Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Anderson Candido

    Aug 27, 2016
    Likes Received:

    I tried to update the airchaft and the update has failed, and then aftet the fail update, I tried again by the DJI assistant 2, with this DJI the aircraft completed the update. After that, the RC and the aircraft didn't conected anymore.
    The RC firmware says that the it is the latest version, but the bind a transmitter has failed and the lights keep blinking in yellow on the aircraft and blinking red in the RC.

    Performed the procedure, did not work

    The DJI support has indicated me a procedure to reset the RC, I did it as they asked but didn't succeded.

    Should I reset the RC and also reset the aircraft?
    What else shoud I do to try to sold this problem?

    Please help me.

    Sorry about my English !! kkkkkkk
  2. msinger

    Approved Vendor

    Oct 30, 2014
    Likes Received:
    Harrisburg, PA (US)
    If you installed the RC firmware before the aircraft firmware, then you'll need to downgrade the RC firmware (like this). Then, follow these instructions to install the firmware on your aircraft, RC, and batteries.
Similar Threads - conecting Phantom Forum Date
4k Phantom 3 4k Wifi dissconecting after crash. Please help Phantom 3 Help Feb 5, 2017
Phantom 1.1.1 not conecting to PC Phantom 1 Discussion Oct 22, 2015
P4 not conecting again Phantom 4 Help Jul 8, 2017
Newbie trouble conecting to p4p Phantom 4 Pro Discussion Jul 3, 2017
Advanced Problem conecting Dji Go app with Sammsung S4 Mini Phantom 3 Help Aug 30, 2015