Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional - P3P RC FW version unknown - No signal

Discussion in 'Pro/Adv Discussion' started by Chris Fellow, Nov 9, 2015.

  1. Chris Fellow

    Nov 8, 2015
    Likes Received:
    Hi all

    First post so don't shoot me please! I'm using an iphone 6 with go version 2.4

    I was updating my firmware on the RC when a phone call came in. I now know to go to airplane mode. My RC (GL300B) shows the cyan light when its powered on. The app reports the controller is connected but has no signal. The firmware version is unknown. I can initiate the firmware update to 1.430 from the app and the cyan light turns dark blue but stays at 0% percent and fails after about 15 seconds as indicated in this post:

    updating RC firmware: blue light stuck on | DJI Phantom Forum

    I tried the C1 C2 Record ISO 4 button combo. When I press this key combo and hold it before turning on the remote the firmware is still unable to update.

    I also tried to update to 1.430 and downgrade 1.3.2 from the microsd in the camera to the RC. I tried placing the BIN files on individually and I'm able to hear a continuous beep but the light remains cyan on the RC after many minutes. Sounds like the same problem as mentioned here:
    Professional - P3P RC firmware issues | DJI Phantom Forum

    I'm not sure what to do but I'm in a nice place and would like to fly since I hauled it here. Any help is appreciated.

    Thanks in advance
Similar Threads - Professional P3P version Forum Date
Sold P3P Phantom 3 Professional with FPVLR Boosted Classifieds Jul 24, 2017
Future support for P3Professional Pro/Adv Discussion Jan 19, 2017
P3P Phantom 3 Professional Parts Classifieds Oct 29, 2016
Packing GoProfessional Case with P3P and Gear Pro/Adv Discussion Dec 3, 2015
FS: P3P, Batteries, SRP Filters, GoProfessional Backpack & more! Classifieds Nov 19, 2015