Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problems with new firmware update process - maybe this will help

Discussion in 'Pro/Adv Discussion' started by Pete Leare, Sep 7, 2015.

  1. Pete Leare

    Aug 6, 2015
    Likes Received:
    Windham NH
    Like many other's have reported today, I too had problems.. First attempt, usual start up sound then a few da..da.da sounds then nothing for 30 minutes except flashing rear yellow lights with solid red front lights. Gimbal led was blinking red during this time.
    Gave up and tried again (yes just the unzipped bin file on the root folder of the formatted SD card and no text files added showing success/failure).
    This time same few beeps at the start then a solid green led on the gimbal almost immediately but no da..dada sounds at all for 30 mins.
    Then thought about what would be different between this update and past (multiple) successful updates, and it was my new PC with USB 3.0 ports. All previous updates were loaded on the SD card using 2.0 ports and this one was done with 3.0 ports.
    I went back to my old PC and used 2.0 ports to copy the bin file to the card and bingo it worked fine.
    Maybe I got lucky the 3rd time but perhaps this will help others to try
    Kenneth Gundersen likes this.
Similar Threads - Problems firmware update Forum Date
Huge problems after update of firmware Phantom 4 Help Monday at 3:36 PM
Problems after P3P v1.11.20 firmware update Pro/Adv Discussion Jul 22, 2017
New firmware update video problems Phantom 4 Discussion Jul 10, 2017
[RESOLVED] P4P firmware update causes no signal and other problems Phantom 4 Pro Help Jun 26, 2017
Firmware Update problems Phantom 4 Pro Discussion Apr 6, 2017