Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problems after shell swap...

Discussion in 'Phantom 2 Vision + Help' started by TruColors, Mar 23, 2015.

  1. TruColors

    Joined:
    Mar 20, 2015
    Messages:
    15
    Likes Received:
    0
    Location:
    Annapolis, Maryland
    I -know- I have satellite lock. Bird flashes green and it stays put in the air despite it being very windy today.

    BOTH the FPV Booster and the DJI apps are not picking up the battery or showing satellites or any other data. It DOES record video from both apps but I have to do it manually.

    I did a shell swap and this started happening after the swap so it has to be me screwing up somewhere.

    Any ideas what to look for?
     
  2. J Dot

    Joined:
    Apr 10, 2014
    Messages:
    2,052
    Likes Received:
    1,063
    Location:
    Sarasota, FL. USA!
    What phantom do you have?
    ( vision or plus ? )

    If vision ( check your white plug in camera )
    Sometimes LOOKS tight, when SLIGHTLY UNPLUGED!

    If plus
    Check wi-fi module ( loose wires, ect ) may be damaged
    Did you crash? Why the swap?

    ALSO, try deleting and reinstalling app!

    ( check firmware versions, might have older app with newer firmware? )

    Take care, keep us posted!
    J Dot
     
  3. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    9,859
    Likes Received:
    4,804
    If you have the P2V+ your symptoms are consistent with the cables going into the gimbal base not seated properly.
    Check the 3 cables that come sown from the Phantom and see they are all properly pushed into their connectors above the camera.
     
  4. TruColors

    Joined:
    Mar 20, 2015
    Messages:
    15
    Likes Received:
    0
    Location:
    Annapolis, Maryland
    My bird is the Vision+ v3. Yes, I crashed it which is why I did the shell swap. I also broke the ESC and had to bust out the soldering gun to replace that. I already posted it on this board in a different thread but if you haven't seen it yet... here's the crash. It's pretty funny.

    https://www.youtube.com/watch?v=2AYVkg6hnGc

    Anyway, I deleted and reinstalled the apps. Rebinded the WiFi. Nothing fixed it until I looked at the "locking" connector to the gimbal. The one that locks into place. One point in the four wire connector was not pushed in. It was damaged from the crash. The gimbal flew out.

    My glorious bird is back in the air now.

    Thank you all for your help and suggestions!!
     
Loading...
Similar Threads - Problems shell swap Forum Date
Problems with new gimbal and or shell. Pro/Adv Discussion Apr 23, 2016
New shell and battery connection problems Phantom 2 Discussion Oct 27, 2015
Connection problems Pro/Adv Discussion 46 minutes ago
Standard back after a long time with problems Phantom 3 Help Yesterday at 6:16 PM
Phantom 4 Remote Problems Phantom 4 Help Friday at 1:38 PM