Problem with charger/battery black pearl

Joined
Jun 12, 2014
Messages
202
Reaction score
2
Age
45
Location
Vernon BC Canada
MY charger light shows that it is powered, when I plug the screen in the light goes red and after 20-30 min the lights goes green. The problem is when I turn the screen on the battery shows one to zero bars. This happens on both batteries. Not sure if I have a battery or charger problem. Anyone else have something like this?
 
Never had that happen to me. I wouldn't think it would be a battery problem...have you turned on the black pearl without it plugged in and see how long the battery lasts? Maybe its just messed up on battery monitoring.
 
Jacob I am not sure how long the battery is lasting. I never like it to shut off mid flight. I should check to see how long each battery lasts thou. Maybe it is the monitor? I have two batteries now.
 
If anyone is interested I finally tested the battery. I charged it up and just left it on. The battery showed zero bars like it was dead but lasted for over an hour switched on!
 
Last edited:
Good test but I think it lasts a little less when you're flying because the antennas and receiver is actually being used I run mine right down then throw in a spare battery & get about 45 min.
 
I only have three batteries so I am happy with an hour. I'm sure it would last a bit less when actually being used.
 

Members online

No members online now.

Forum statistics

Threads
143,084
Messages
1,467,519
Members
104,960
Latest member
poojacuisine