Problem Litchi/Gimbal

Joined
Dec 9, 2016
Messages
3
Reaction score
0
Age
119
Hi,

I just installed Litchi and I have a problem concerning the gimbal movments. When I use the pitch on the smartphone, it moves the gimbal to 90° in one shot and less than 1 second! I can't move it smoothly and slowly... Any idea of the problem?
Thanks
 
Joined
Nov 28, 2016
Messages
467
Reaction score
176
Location
Wisconsin
Only adjustment I read is when using VR mode. You can adjust the speed of the gimbal movement when moving your head. Can't find any other adjustment, unfortunately. Perhaps it can be set in DJI Go and then it will operate in Litchi? Worth a try.
 
Joined
Dec 9, 2016
Messages
34
Reaction score
0
Location
Dorset UK
Lost control of gimbals on a Litchi curved turns mission, the footage showed when the P4 went behind the small church for about 10 - 15 seconds the camera pointed directly to the ground only returning to the (POI) when P4 was back in view and passing the next WP. I have updated the mission with a lot more WP hoping it will regain the signal sooner, hoping to test when weather permits.

Question when changing altitude while pointing at a (POI) the gimbals settings are being changed constantly where is that being calculated on the bird or the iPad?
 
Joined
Jan 27, 2016
Messages
2,409
Reaction score
892
Location
Ohio
Not sure where the calculations take place, but the manual clearly states that the gimbal will not track different POIs or change angle when the bird is 'Lost link'
 
Joined
Dec 9, 2016
Messages
3
Reaction score
0
Age
119
Ok, found the problem. I must slide my finger from before the zone (up or down). If I choose to touch the line directly, it moves directly.
 
Joined
Dec 9, 2016
Messages
34
Reaction score
0
Location
Dorset UK
Not sure where the calculations take place, but the manual clearly states that the gimbal will not track different POIs or change angle when the bird is 'Lost link'
Thanks Richard
The actual signal loss happened between two WP's both pointing to the same POI at the same altitude and same gimbal pitch of -1 but during the signal loss (out of sight) the gimbal went to -90 straight down I thought it would have remained at the -1 setting from the last WP. It returned to -1 when the bird arrived at the next WP.

Should the gimbal not have remained at -1 when the signal was lost?
 
Joined
Dec 9, 2016
Messages
34
Reaction score
0
Location
Dorset UK
Just had this confirmed from Litchi
The gimbals are controlled by Litchi (mobile device), if you lose signal, the gimbals behavior is undefined.

I know the Go App doing a POI the gimbals remain steady, going to test an orbit around the same POI with Litchi to see if I get the same loss of control ?
 
Joined
Dec 12, 2016
Messages
2
Reaction score
0
Age
64
Just had this confirmed from Litchi
The gimbals are controlled by Litchi (mobile device), if you lose signal, the gimbals behavior is undefined.

I know the Go App doing a POI the gimbals remain steady, going to test an orbit around the same POI with Litchi to see if I get the same loss of control ?
Litchi also has more control options that GO does with regard to the gimbal, depending on what function you're in. One of the built in options for GO and Litchi is for the gimbal to move 90 degrees immediately, either up or down, depending on current position. This can be assigned to one of the buttons on the bottom of the controller. It can also be a Litchi command if you're running a mission.
 
Joined
Dec 9, 2016
Messages
34
Reaction score
0
Location
Dorset UK
Litchi also has more control options that GO does with regard to the gimbal, depending on what function you're in. One of the built in options for GO and Litchi is for the gimbal to move 90 degrees immediately, either up or down, depending on current position. This can be assigned to one of the buttons on the bottom of the controller. It can also be a Litchi command if you're running a mission.
Perhaps I did not explain the issue very well.
As part of a larger mission this small section where the error occurred is circling a small derelict building all these WP set to the same POI and Focus POI, the POI altitude is 20ft the bird altitude is 25ft the gimbal pitch shows -1, as the bird passed behind the building "I think I must have lost signal" the gimbal dropped to -90 then back up to -1 upon arriving at the next WP. The bird was only out of sight for a few seconds. With DJI Go app doing the same POI this never happened.

The question is; should the gimbal not have remained at -1 when the signal was lost until the next WP?
Perhaps changing the WP just before the bird goes behind the building to Interpolate with the gimbal pitch -1 might be the answer?


I am new to forums in general as I have not had any issues before using the DLI Go App but now switched to Litchi with my P4 which I find much better planning with mission hub etc.
 
Joined
Jan 27, 2016
Messages
2,409
Reaction score
892
Location
Ohio
Litchi specifically states that gimbal position is unpredictable when you go 'lost link'. Not surprised that it doesn't recover until the next waypoint. That would be when the next gimbal command would be sent.
 
Joined
Dec 12, 2016
Messages
2
Reaction score
0
Age
64
However, there a examples of Litchi correctly completing a mission even with lost signal (I've seen several on YouTube). It seems that once the mission is uploaded that it will do what it was told to do, regardless of signal. I can understand unpredictable control of gimbal if you're using Litchi to fly manually, but when running a programmed mission?

Has the pilot double checked all of the Litchi settings at the point of failure, just to make sure that the gimbal change wasn't somehow programmed? Still, it's all computers (prone to glitching), software (which is never perfect or fool proof), and airwaves (full of various signals at various wave lengths), so it could also just be a one-off thing due to unpredictable environment.
 

New Threads

Forum statistics

Threads
136,671
Messages
1,413,292
Members
99,354
Latest member
rkmobile