Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom Wont Calibrate (Red Flashes)

Discussion in 'Phantom 2 Help' started by Robin van Buuren, Oct 7, 2015.

  1. Robin van Buuren

    Oct 6, 2015
    Likes Received:
    Joure, Friesland, The Netherlands
    Hello Dear Phantom Pilots Colleague’s

    A few months ago I bought a DJI Phantom 2 with a Futaba T8J TX I have owned several other Phantoms so I knew the product very well. But this one is different than the rest,

    I can’t really calibrate the GPS by doing the DJI Dance… but when I waited I would get full satellite cover. So I went out and tried to fly. (I live in Holland so lots of big open spaces where I can fly.

    Yep of course also a lot of Transmission towers but I have flown here before with a other phantom and never had a problem. ) So I went out Took off and watched how the drone flies. In the beginning nothing special but the drone didn’t hold position so good at 4 a 5 meters high.

    Suddenly the drone lost height and I could just manage to land it… I looked at it and thought well maybe I did something wrong so checked everything and tried it again.

    The drone went up and yeah again It didn’t keep position so good so I tried to go lower to the ground to see if it would go better. Nah you know the answer drone crash… no damage lucky.

    But within a few days I would go to Croatia so I wanted to know what the problem was so I could fly over there and make some nice shots of the campsite and the area. I fixed the problem at last I thought so just by Recalibrating the Compass. In the DJI phantom Assistant software.

    I do the DJI Dance and yeah lights go out and then 1green 2 red so less than 9 satellites but after a few seconds fast green flashes and after that It went on with 4 solid green flashes. So full satellite cover. So I thought I fixed the problem. Took the phantom, took off, made some pictures, fly over the sea, come back, try to land, all very steady.

    Managed to do a few flights over there.

    And It flew pretty good a bit Shockey at heights with steering’s and a little drift away.

    So I thought Eureka! But coming back to the Netherlands same story cannot Calibrate the GPS/Compass. After the DJI dance Lights go in fast flashing Red so put it up to the computer and watched wat the software said. Same as every time error 27 GPS “GPS calibration failed or strong magnetic interference” so I tried it again but now being plugged in the computer to see what my sensors are doing. But see nothing strange the MOD keeps in the Save distance (below 750 or beyond 2250 is not good and error will pop up)

    But after the calibration I saw a fast disappearing message saying Basic Calibration fail.

    So I did the Basic IMU Calibration and to finishing it all I also did the Advanced IMU Calibration.

    And guess what…

    The calibration had succeeded so I powered the drone down. Took it outside powered it up did the dance and again Red flashes. So took my laptop outside hook it up same story. Now it seems that I can only calibrate the GPS if I do an Advanced IMU Calibration.

    Sorry for the long story I will list everything below:

    I hope someone of you knows the problem or knows what to change.

    Setup :

    · Dji Phantom 2

    · Futaba T8J

    · Feiyutech gimbal

    · Go Pro Hero 3 +

    · Immersion RC Vtx


    · Drone can’t hold position so good.

    · Drone drifts away.

    · Can’t calibrate the GPS/Compass.

    Things I tried :

    · Change TX settings.

    · Recalibrate GPS.

    · Calibrate IMU.
  2. Robin van Buuren

    Oct 6, 2015
    Likes Received:
    Joure, Friesland, The Netherlands
    Anyone who can help ????
Similar Threads - Phantom Wont Calibrate Forum Date
PHANTOM 2 VISION+ Wont calibrate? Help? Phantom 2 Vision + Discussion Sep 21, 2014
Standard Phantom 3 standard wont start Phantom 3 Help Jul 9, 2017
Phantom 3 standard controller wont turn on? Standard/4k Discussion Jul 3, 2017
phantom4pro+ wont connect to wifi Phantom 4 Pro Help Jul 3, 2017
Standard Phantom 3 wont start? Phantom 3 Help Apr 17, 2017