Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom P2 won't acquire satellites

Discussion in 'General Discussion' started by glatucci, Apr 13, 2014.

  1. glatucci

    Apr 13, 2014
    Likes Received:

    I'm very new to quad flying. I received my Phantom P2 last tuesday. I have a problem with green/blue colors so its difficult for me to see the yellow flying lights and then the green. But besides that issue. When I turn on the transmitter, then turn on the P2 I wait for it to acquire satellites which would show as rapid blinking. So even if i cant see its yellow I know it acquired at least 6 satellites and now I can flip the S1 on my transmitter 6 or 7 times until the color is solid. then rotate horizontally then when its green then vertically. The problem is it never acquires satellites. I wait like 3 minutes. Im in the Bronx, I know its not the most suitable place to fly, but according to my android app theres 10-15 satellites in view here.

    I downloaded the Assistant software and may have updated the firmware by mistake, Im not sure. But before I updated anything there was a message about a "firmware mismatch". Its still there. it also says your P2 isnt calibrated due to magnetic interference, please re-calibrate.

    I'm close to returning the P2. I really don't want to. I already bought the HERO 3+ and was looking forward to taking aerial videos with the Zenmuse gimbal. Does anybody have any ideas on how I can get the P2 to acquire? Thanks in advance.
  2. J Dot

    Apr 10, 2014
    Likes Received:
    Sarasota, FL. USA!
    This is only my opinion,
    But sounds like mostly compass calibration, and poor satellite signals!

    I will say when I updated my firmware, it told me firmware mis-match as we'll, and after upgrade assistant said recalibrate.
    I ( again only my opinion, and what I would do! )
    1) make sure you have latest PC ASSISTANT SOFTWARE!
    2) start phantom ( NO PROPS ) ( start controller, range extender, and P2 )
    3) hook P2 to PC ASSISTANT
    4) download LATEST driver
    5) update any firmware not updated ( you can check under assistant )
    7) DOUBLE CHECK everything is up to date
    8) turn off and unhook from PC
    9) go outside ( props off ) just in case, try to find the most OPEN AREA, you can ( no big buildings, trees, concrete ect )
    Try recalibrating compass at this location ( to insure good compass lock )
    From here
    I would rehook phantom to software. ( PC Assistant ) and see if error messages have disappeared?

    As for the satire lite link, I have waited as long as 8 minutes to achieve 6 satellites , just to get home lock, and sometimes I get home lock before I can even hook to wifi!
    I would not get discouraged ( also MAKE SURE BOTH TOGGLE SWITCHES ARE UP ) before you turn controller on!
    To insure you are in GPS MODE!

    Hope this helps, I'm no EXPERT, but I think simple deduction will prevail!

    Honestly, I think because where you are, you are just not getting a good satellite lock, or compass lock?
    Also when calibrating compass ( take your time, slow, level, and steady ) you have plenty of time to complete calibration, ( keep controller, keys, cell phone, and basically anything metal or magnetic ) away from phantom when calibrating!
    From solid yellow lights
    1 spin level ( phantom level with ground )( lights turn green )
    1 spin ( phantom front pointed at ground ) ( lights go back ( yellow or green blinking ) depending on GPS LOCK!
    Wait for fast green blink ( at least 6 satellites ) home lock, followed by slow flash green!
    Then safe to fly!

    Hope this helps please let us know?
    Jerry D
    ( J Dot. )
  3. ianwood

    ianwood Taco Wrangler
    Staff Member

    Jan 7, 2014
    Likes Received:
    Lost Angeles
    There have been some cases where the GPS cable was not plugged into the main board. You should be able to tell pretty easily. Make switch S1 on the controller is in the top position. Go in the Phantom Assistant and look in the bottom left corner, it should say GPS ATTI. If it just says ATTI, then your GPS unit might be either disconnected or not working.
Similar Threads - Phantom won't acquire Forum Date
Phantom 4 motors won't fully start Phantom 4 Help Jul 20, 2017
Phantom 3 Standard won't rev or launch Standard/4k Discussion Jul 13, 2017
Phantom 3 4k controller won't charge past 2 LEDs Standard/4k Discussion Jul 9, 2017
Phantom 3 advanced remote won't turn on unless plugged in. Pro/Adv Discussion Jun 8, 2017
Won't connect to osmo after flying phantom 3 pro Pro/Adv Discussion May 29, 2017