Phantom 4 Pro AC/RC linking problem

Joined
Dec 8, 2022
Messages
2
Reaction score
1
Age
35
Hi , all ! :)
Iam encountering problem with my P4P. I had a little crash .. ribbon cable to the camera was damaged ... after replacing it ... everything was ok and working .. all functions tested .. calibrated etc .. everything was ok. After puting all together and tightening ... iam no longer able to link rc to ac.
What i have tryied so far:
Double and triple checked all conections
Linking via DJI GO4
Manual linking
Refreshing FW via DJI Assistant 2 (current version 1.05.600 - fw update remains stuck at 24% everytime)
Downgrading FW via DUMLdore ( it gets stuck at same percentage 24%)

At this point i am not sure if its hw or sw related problem.

After powering up AC acts normaly. Gimbal does its calibration thing. Led sequence RED - Green - Red ... then remains flashing yellow ( gimbal is flashing orange)

I would apreciate every help ... since drone is no longer waranty covered :X

thx and sorry for bad english
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,800
Reaction score
2,318
Age
71
Location
IRB, Fl
Most common problem: If using 300F or E remote make sure rc set to transmit @ 5.8G not 2.4 to link. Can be switched back afterwards if needed. It's done in HD Image Transmission Settings, frequency. Also displays at top of screen Go4 (HD)5.8 or 2.4.
 
Joined
Dec 8, 2022
Messages
2
Reaction score
1
Age
35
Thanks for reply :)
I have found what was the problem.
I used screw with wrong lenght on clip which is securing flex cable from mainboard to camera. Which was fatal for capacitor under the heatsing. :eek:o_O

WIN_20221208_18_16_46_Pro.jpg
WIN_20221208_18_38_46_Pro.jpg


after replacing it everything works as before.

its located right under the hole for the screw in heatsing ... near cam conector.
Maybe this will help someone in the future :)
 
  • Like
Reactions: Droneted

Recent Posts

Members online

Forum statistics

Threads
142,369
Messages
1,461,898
Members
104,172
Latest member
schoolnetindia