P4P RTK Z Axis

Joined
Aug 29, 2019
Messages
5
Reaction score
0
Age
28
Hi,

Does anyone have experiance with the P4P RTK & PIX4D Processsing.

Flew my first flight on site last week and all seemed to go well and quality report shows great residuals with the gcps, but upon inspection of the point cloud there is around 2m of error in height.

All GCP's have been traversed in using a total station

The drone was flown in RTK mode connected to smartnet, my only thought is that it requires more tie in points due to the changes in elevations over the project.

qr.PNG
gcp2.PNG
 
Joined
Mar 8, 2019
Messages
4
Reaction score
0
Age
44
Hi mate.

Yes I have been learning about this awesome drone over the past few months.

The results are amazing!

I find when flying in RTK mode connected to my RTK license, I use an offset from GRS80 ellipsoid for the local area (website or local measurement gives me the same input offset numbers) and when I look at images to mark ground control there is very rarely more than 50mm to adjust (which at 100m above takeoff is amazing).

Your results look amazing.

I have had a similar error in the past on a flight and it was due to my pole height when marking the gcps. I had the pole height on my rover incorrectly set to 0 and not 2m. Worth checking anyway. This would perhaps explain the awesome residuals and 2m offset in the z with the accurate RMS Z errors. I have made this mistake in the past and that is how I know this possibility.

This would make even more sense if - when you were marking the GCPs in Pix4d - if you had to shift the target around 100-150mm in each image (as it would have been projecting a point to 2m above or 2m below) depending on the angle the photo is taken when looking at the GCP (if directly above you would not need to shift the control too far).

Other than that I'm struggling to think of another error source. Maybe when you export the GCPs from your total station you export the ellipsoid height accidentally rather than the local? Not sure about this one.

Anyway, hope this helps.

Would love to know what the problem was if you find it!!!

Mark.
 
Joined
Aug 29, 2019
Messages
5
Reaction score
0
Age
28
Hi Mark,

Cheers, im certain that all the control is correct, and my import co ordinate system is wgs84 from the P4P RTK.
Where i believe im getting confused is with the output co ordinate system on the GCP's i had just selected OSGB1936 and upon looking at the tutorials on pix4d's youtube channel they click the advanced box and play around with the vertical datum, should this just be set to arbitary?
 

Attachments

Joined
Mar 8, 2019
Messages
4
Reaction score
0
Age
44
Yes absolutely you need to select the XY local datum for coordination and then tick the advanced options and tick arbitry otherwise it will default to ellipsoid height which is not what you want.

Alternatively when flying in rtk mode you will be amazed at the accuracy when you simply apply a vertical difference between the grs 1980 ellipsoid and your local datum (this is set to 0 by default in the advanced settings).

In Australia there is a website to give you this information (you just need to type in the lats and longs of the site which I get off Google Earth) and it tells you the offset to type in.

Otherwise you should be able to measure it on site as I do with my Topcon Rover.

Hope this helps mate.

Mark
 

New Threads

Forum statistics

Threads
136,169
Messages
1,408,384
Members
99,077
Latest member
charlie_usa