P4 battery - only charging intermittently - no lights

Joined
Jul 25, 2014
Messages
243
Reaction score
12
Location
Europe
I know this has been asked before, but in my case it happens a bit differently. So I have a P4 battery which I was about to recharge after being stored unused for about 3-4 months, I noticed the same thing also happened last time when I recharged the battery. So I was successful in charging the battery in the beginning, then I took it off the charger for a few minutes, and then when I tried to continue charging the battery it wouldn't charge anymore, and no lights lit up.
I then succeeded to get it to charge again by holding the button down somehow while the charging cable was connected to the battery, don't really know what I did?
Anyway, since this has happened before I wonder if this indicate that the battery is bad somehow, and what might be causing this. Can the long term storages which I have been doing for a couple of years with only very little flying in between have affected the battery in a negative way, even though I have followed the protocol for long term storage, and despite the battery only having 10 charge cycles in total?

The battery has always been stored at around between 51% - 60%, and in normal room temperature.

Thanks in advance.
 
Last edited:
Joined
Dec 25, 2016
Messages
1,918
Reaction score
1,167
Location
Tucson, Arizona
May want to check what each cell is reading in the app. They should be close to each other in that regard. Fire up the aircraft (stay low)to load the battery and watch what it reads. Discharge and recharge a few times and watch what it’s doing.
 

New Threads

Members online

Forum statistics

Threads
140,618
Messages
1,449,370
Members
102,427
Latest member
ldti