P3P compass won’t calibrate - seeking advice

Joined
Jan 1, 2016
Messages
3
Reaction score
1
Location
Scotland, UK
Happy new year all! Been lurking here since ordering my P3P, but now that it’s arrived, I’ve run into an issue that I need some advice with.

After I got everything unboxed and charged, I switched the aircraft on and it told me that there was a compass error, and it needed to be calibrated. After a few attempts at the compass dance outside on my lawn (~15m away from house, with no keys, watch etc on me, closest metal was RC transmitter + iPhone a few meters away so i could see when the calibration instructions change axis), it would still just say the calibration failed and tell me to try again.

There were a few other errors listed relating to firmware needing to be updated for aircraft, RC, and battery, so I went ahead and upgraded those to see if it somehow resolved the issue. Upgrade to v1.6.0040 (2015-12-22) was successful, but still no joy with the compass calibration. A few forum posts and articles suggested that recalibrating the IMU could resolve compass errors, but that didn’t fix anything for me either.

I figured the next thing to try was some significantly different physical locations, in case my house/garden is geologically cursed. I’ve tried in three other locations:
  • In the middle of a large open field adjacent to my house.
  • A countryside field about 15 minutes drive north.
  • A local park/football field about 5 minutes drive south.
…and yes, I’ve been deliberate about checking I don’t have metal objects on my person when attempting calibration.

The last thing I tried was attempting to degauss the compass using a magnet (as per some youtube videos), but that didn’t seem to change anything either.

I noticed a few articles and forum posts about calibration referring to the compass sensor values being way outside the normal range, but my compass sensor values are completely blank (see screenshots at bottom). Immediately after doing an IMU calibration they begin to show zero values for x, y, z, and mod, but as soon as I attempt a compass calibration, they go blank again. Could this help narrow down what the problem is?

I’m running out of things to try. Here’s the remaining options, as I see them:
  • Wait DJI support are back from holiday and hope they can assist somehow
  • Take the top shell off the aircraft to check compass cable is connected properly to the main flight controller.
  • Buy a replacement set of landing gear + compass
I’d really appreciate any advice for getting past this issue so I can get airborne!

Screenshots:
  • Aircraft state screen:
  • Compass error (when tapping the "abnormal" question mark):

  • Overall status:
  • Compass dance failed error:
  • Compass sensor values blank:
Any suggestions would be awesome :) Thanks in advance!
 
Joined
Jun 11, 2015
Messages
645
Reaction score
184
Age
56
What device are you using? iPad , iPhone ? Have you tried uninstalling the Go app and reinstalling it, they have had some issues with the install and reinstalling it helps. The compass mod value should be around 1500 and yes do it away from any metal.
 
  • Like
Reactions: cobyism
Joined
Nov 16, 2013
Messages
79
Reaction score
33
Location
Somerset, UK
Sounds like its faulty, as you've tried the obvious things - annoying, but if you only just received this I would just contact seller for a replacement, DJI repairs would take much longer !
 
  • Like
Reactions: cobyism
Joined
Jun 11, 2015
Messages
645
Reaction score
184
Age
56
Someone awhile back had the same issue, I told them to uninstall the Go app and reinstall took care of the issues he is having. Only will take a few minutes.
 
Joined
Jan 1, 2016
Messages
3
Reaction score
1
Location
Scotland, UK
What device are you using? iPad , iPhone ?
I’ve tried using both iPad and iPhone, and I experience the same issue regardless of device. The screenshots above are from the iPhone.

Have you tried uninstalling the Go app and reinstalling it, they have had some issues with the install and reinstalling it helps.
Thanks for the suggestion. I tried reinstalling the app on my iPhone just now, but it hasn’t resolved the issue.

The compass mod value should be around 1500
As I mentioned in my post (and in the screenshots), all the compass sensor values are either blank or zero. Do you have any ideas for resolving a situation like mine, where the compass mod value is zero?
 
Joined
Jun 11, 2015
Messages
645
Reaction score
184
Age
56
There was a post from someone a few weeks ago on the DJI website with the exact some issue and uninstalling and reinstalling cured his problem. Sorry, sounds like you've done everything else, hopefully DJI or where you purchased it will take care of it quickly.
 
  • Like
Reactions: cobyism
Joined
Jan 1, 2016
Messages
3
Reaction score
1
Location
Scotland, UK
There was a post from someone a few weeks ago on the DJI website with the exact some issue and uninstalling and reinstalling cured his problem. Sorry, sounds like you've done everything else, hopefully DJI or where you purchased it will take care of it quickly.
No worries—thanks again for the advice and suggestions, I really appreciate it! :)

Unless anyone can suggest anything else, I’m going to contact the seller and see what they can do.
 
  • Like
Reactions: Jbundy63
Joined
Dec 23, 2015
Messages
60
Reaction score
18
Age
53
I had the same problem the last time I flew my P3P. I turned off both my iPhone a my son's iPhone. I was able to calibrate the compass after doing that.
 

New Threads

Forum statistics

Threads
137,447
Messages
1,420,634
Members
99,825
Latest member
MarshMadness