Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware P3 upgrade firmware does not start in brand new quad

Discussion in 'Firmware' started by marciano, Aug 22, 2015.

  1. marciano

    Oct 9, 2013
    Likes Received:
    I am a P1, P2 and now a P3 user.
    Here I have my new, just unboxed P3 Prof.
    Here are steps I've done after unboxing

    I use DJI Go in an iPad 2 mini.
    Charged battery and RC.
    Opening the app the first time I got a warning 'upgrade firmware'.
    I tapped that line and a progress bar downloading a firmware showed up.
    I saw a blue led in RC.
    Finishing that it still displays three warnings about upgrading the aircraft, RC and battery.
    I went to DJI P3 downloads and got P3S_FW_V01.03.0020.bin I copied to the micro SD card I previously formated from the aircraft.
    I followed pdf instructions and turned P3 on (not the RC). It starts as usual and after checking its system camera light remains off while rear lights blink yellow quickly (because there's no RC connection)
    So firmwares are not performed. I remember that some settings I've changed before the upgrade from the app where reset to their defaults after that. So it seems something has been upgraded but those three warnings remain.
    Seems like I've first upgraded the RC according to the pdf enclosed in the firmare.zip file. I got it after I saw more firmware updates warnings.
    If the first time I build the system, the app presents me a way to update firmwares (tap and go) it is supposed (I'm not a diviner) I have to be warned about first downloading and running the aircraft firmware and then tapping the 'update firmware' link.

    I also got some know bugs testing recording videos and taking photos: sudden No Signal, no video feed to the screen.

    What can I do?
    IMG_0054.jpg IMG_0055.jpg
    #1 marciano, Aug 22, 2015
    Last edited: Aug 22, 2015
  2. marciano

    Oct 9, 2013
    Likes Received:
    I formatted the card in mac disk utility and now the firmware is upgrading
  3. bautomata

    Sep 1, 2015
    Likes Received:
    I had the same issues, tried to update the firmware and it didn't work, then I got "No Signal" and black on the video feed. I formatted my SD card, tried all the firmwares available and nothing. Thankfully this happened within a week of my ordering so back to get exchanged for a new one.

    Did you ever get your video signal back?
  4. romi

    Aug 10, 2014
    Likes Received:
    Hi Marciano. I just updated my brand new P3P last night. The rc will not update from an SD card, only OTA. I had a tough time and never succeeded with my satellite connection but on the second try with my 4g connection I got the download. After the download don't forget there is still the "button" to click to execute the install. Hope this helps.
Similar Threads - upgrade firmware does Forum Date
P4P does not upgrade to the new firmware Phantom 4 Discussion Apr 3, 2017
New P3P - does it need firmware upgrade? Pro/Adv Discussion Aug 21, 2015
P3 Firmware Firmware fail: [01886141][19 00] Firmware upgrade finish failed (step = 2, err = 0x08) Firmware Saturday at 4:45 PM
P4 Upgraded Firmware in Drone, Remote and DJI Go 4 app, Drone will not take off Phantom 4 Discussion Aug 9, 2017
Professional Controller lost connection to the Phanton 3 Prof after a Drone/Controller firmware upgrade Phantom 3 Help Aug 6, 2017