P3 Standard rc signal lost, last firmware issue

Joined
Jan 1, 2016
Messages
16
Reaction score
0
Age
24
Hi!
I read a lot of topic about this but nothing helped me.
So i upgrade the firmware with no problems. In the end of the upgrading the app said restart my aircraft and controller. After that yellow led flashing in the drone and in the app shows "rc signal lost". I try to re link a lot of times, i format the sd card but nothing. I try to reupgrade the firmware but it always stop at 20% and 49% than it say upgrading fail.
I am sad because i got the drone few days ago and a factory upgrade destroy it.
 
Joined
Jan 1, 2016
Messages
16
Reaction score
0
Age
24
I dont know... I think there was a big trouble inside the software. in my opinion the idea from the development that upgrade the drone via smartphone isnt a good thing.
First i deleted the phantom wifi from my iphone.
I reseted my controller wifi (
)
I turned on the aircraft and i reconnect my phone to the phantom wifi
Then i started to upgrade again.
Fortunatelly everything was ok. While i doing that i heard a lot of noise from the aircraft and from the controller but in the end everything worked.
 
Joined
Jan 1, 2016
Messages
11
Reaction score
0
Age
48
I had a pretty bad crash yesterday the 8 grey wires that plug the camera in were ripped out as well as the dark grey wire. I'm pretty sure i connected them properly. But now the p3 link light is green and the controller light is red. The app in the camera view says it is disconnected. Any ideas?
 
Last edited:
Joined
Jan 1, 2016
Messages
16
Reaction score
0
Age
24
I had a pretty bad crash yesterday the 8 grey wires that plug the camera in were ripped out as well as the dark grey wire. I'm pretty sure i connected them properly. But now the p3 link light is green and the controller light is red. The app in the camera view says it is disconnected. Any ideas?
Have you tried to relink ?
 
Joined
Jan 1, 2016
Messages
11
Reaction score
0
Age
48
Yeah I did and the controller just keeps beeping and the red power light stays on never turns green


Sent from my iPhone using PhantomPilots mobile app
 
Joined
Jan 1, 2016
Messages
11
Reaction score
0
Age
48
I did. Funny thing is when I turn both the controller and drone on the drone light turns green like it's linked but the controller does not


Sent from my iPhone using PhantomPilots mobile app
 
Joined
Dec 24, 2015
Messages
52
Reaction score
9
Age
66
I had a pretty bad crash yesterday the 8 grey wires that plug the camera in were ripped out as well as the dark grey wire. I'm pretty sure i connected them properly. But now the p3 link light is green and the controller light is red. The app in the camera view says it is disconnected. Any ideas?

If that ribbon cable is not correct and connected, the drone will not link correctly. Even if the camera is broken no ribbon cable, no fly.
 
Joined
Jan 1, 2016
Messages
11
Reaction score
0
Age
48
Thanks for the help. I'm taking it to a shop to have them look at it


Sent from my iPhone using PhantomPilots mobile app
 
Joined
Jan 23, 2017
Messages
2
Reaction score
0
Age
37
My post crash left me with similar symptoms. The yaw arm broke off, I replaced that and the ribbon cable for the motors. The app shows the RC connected but no AC. Here is the catch, I can still fly with the RC just no feedback to the app. Can't verify home point, can't see battery status or set up any of the flight funtions. It's just a really expensive quad.

Did you get your working John?
 

New Threads

Forum statistics

Threads
140,868
Messages
1,451,350
Members
102,709
Latest member
mbah2017