P2V+ not connecting to assistant

Joined
Apr 29, 2015
Messages
6
Reaction score
0
Age
41
Had it a few months, no issues, no wrecks. Have only connected it to the assistant one other time, and it worked fine. I tried connecting it to update everything, and it keeps telling me to connect the controller (I know this means phantom). Ive tried different USB cables, my mac, and another laptop. The lights at the bottom of the assistant window indicate nothing is connected.
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,582
Reaction score
10,027
Location
Harrisburg, PA (US)
Try reinstalling the Phantom Assistant application and DJI WIN driver (if running Windows). You can find those here.
 
Last edited:
Joined
Apr 29, 2015
Messages
6
Reaction score
0
Age
41
thanks, but i've already deleted t and reinstalled it several times. primarily using mac
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,582
Reaction score
10,027
Location
Harrisburg, PA (US)
Did you try again on your laptop? If not that would be worth a try.

Did you make sure you're using the USB cable that came with your Phantom?

Finally, (sorry, I have to ask) where are you plugging in the USB cable?
 
Joined
Apr 29, 2015
Messages
6
Reaction score
0
Age
41
lol no worries...using the microusb port on the phantom, the usb side is in my macbook. using the dji cord now. have tried several other cords and other laptops (windows) with no luck. emailed dji, haven't heard anything yet
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,582
Reaction score
10,027
Location
Harrisburg, PA (US)
using the microusb port on the phantom
There are two ports. Make sure you're using the port beneath the white flap (and not on the gimbal).
 
Joined
Apr 29, 2015
Messages
6
Reaction score
0
Age
41
I make fun of people that make mistakes like that. I should've just kept quiet lol. Thanks
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,582
Reaction score
10,027
Location
Harrisburg, PA (US)
It happens even to the best of us :)
 
Joined
Apr 29, 2015
Messages
6
Reaction score
0
Age
41
I've never felt this dumb lol. Thanks again, fly safe...oh, and the Love Field thing...whoever that was... stop being dumb in my city!. Someone is going to get in serious trouble for that
 

New Threads

Forum statistics

Threads
133,999
Messages
1,387,162
Members
97,733
Latest member
Patrick T