Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P2 Bizarre Behavior

Discussion in 'Phantom 2 Discussion' started by evonbart2, Jul 8, 2014.

  1. evonbart2

    Jun 20, 2014
    Likes Received:
    Had an episode with my P2 I have to investigate. I was in an open area, along a river, flying around a structure. It was about 300m away - in visual range and responding fine to my RC. I saw no FS popping up, so it wasn't out of RC range. I started to descend from about 150ft to about 100ft. I let go of the throttle stick and the quad kept descending. Not fast, but at the same pace it normally does when I give it a command to descend. I hit max throttle UP and nothing. It lowered below my visual ability to see it and said "Oh shyt - Oh shyt" about 20 times as I waited for FPV to go black as it splashed down into the river. It didn't. For some unexplained oddball reason, it stopped at 2m and hovered for about 5 or 10 seconds and then started to lift and respond to my throttle up command. As soon as I got altitude (100ft) I punched it back to my direction and started to land it. It started doing the weird descent behavior again of not responding to my throttle up and I thought it was going to crash onto a vehicle parked in the lot.

    I have about 200 P2, P2V and P2V+ flights under my belt, so I'm not inexperienced.This is something that I have never seen and before someone says throttle down (during flight) for more than 3 seconds should activate auto land - that's 100% wrong. I have hit the max altitude (400ft) many times and then descended from there to landing height - holding the left stick down the entire time and never once did it go into auto land and never once did it NOT respond to other commands to lift or move laterally.

    I'm going to investigate a few things.
    - Is the transmitter antennae I just installed too close to the compass? Down was the only command I gave that it acted weird with.. pitch, yaw and ascent all worked perfectly.
    - Are the RC batteries low? I get no warning beeps yet from it, but if it does the same thing with full-charged RC batteries, that rules that out.
    - Is there a new problem from the firmware update I made to resolve the toilet bowl effect problem it was having a few weeks ago?

    I'll look more for posts on this topic, but so far not seen anything. Any thoughts?

    My first thought is, I'm tired of giving DJI 2nd, 3rd and 4th chances and researching other quads or UAVs. I'm a photographer / cinematographer and I just want a flying camera that works. I do not want to spend my valuable time perpetually searching out issues that make my Phantom act erratic and have me questioning the safety of it. I already lost one P2 full FPV kit and all to an unexplained drop out of the sky and now I almost just lost another. This forum is a great place with a lot of valuable feedback - I don't want to sound like a whiner, but I think it's important for all of us to share our experiences, positive or negative, so others might learn and maybe save them some of the grief.

    It's a shame too because I added a new FPV (immersion RC) and I'm not kidding - at 1500 ft distance the screen was crystal clear. If I solve the mysterious descent problem, I'll post about that and my FPV rig.

  2. Ejazzle

    May 7, 2014
    Likes Received:
    i have had the same problem with mine. Stock p2 with h33d
  3. OI Photography

    Sep 23, 2013
    Likes Received:
    Clarksville, TN
    While what the behavior you posted about wasn't caused by autoland (at least not by that alone), it's well documented that it does activate whenever you have your cutoff mode set to intelligent and you hold the throttle stick all the way down for 3 or more sec. If you held it all the way down during the whole descent then you wouldn't have noticed it working anyway, and it would have been countered as soon as you applied throttle above 50%, and lateral movements would still work as well...which is exactly what you experienced the previous times you mentioned.

    In your current situation, I would guess that either autoland was triggered and the Phantom didn't pick up your counter-input immediately, or the descent was indeed caused by something other than autoland.

    Does this behavior persist across multiple batteries? One of the several possible causes of this is a cell in the battery starting to go bad and causing it to not deliver adequate or consistent power at all times.
Similar Threads - Bizarre Behavior Forum Date
Bizarre run-away altitude on return home Phantom 4 Pro Discussion Dec 31, 2016
Pics of the most bizarre objects strapped to your bird General Discussion Dec 15, 2016
Bizarre firmware experience, 1 Battery already updated? Pro/Adv Discussion Jun 28, 2016
Worked with The Travel Channel - Bizarre Foods General Discussion Apr 13, 2016
Bizarre IMU Calibration issue Pro/Adv Discussion Jan 29, 2016