Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Chook

    Joined:
    Aug 18, 2016
    Messages:
    2
    Likes Received:
    0
    I'm a new pilot and this is my first post. I purchased a Phantom 4 exactly one month ago and today I'm having a problem with it. After powering up I get the status "No Image Transmission Signal", it then changes to "Safe to Fly" briefly (and I get a camera image), it then goes back to the "No Image Transmission Signal" and cycles through these two message for a while before it end on the "No Image.." message.
    I also note that the Gimbal Status is "Gimbal Disconnected".
    I've tried updating firmware but I get a "failed" message.
    Any ideas?
     
  2. Chook

    Joined:
    Aug 18, 2016
    Messages:
    2
    Likes Received:
    0
    Problem solved. Once I refreshed the firmware it cleared up the problem. My issue was that I could not update/refresh the firmware because of some issue with the MicroSD card that I was using. When I went back to the original one included with the Phantom 4 the option to refresh the firmware was available in dji assistant 2. Once refreshed it now all appears to be normal. (I did use the problem MicroSD card in another device).
     
  3. r62ewa

    Joined:
    Mar 30, 2016
    Messages:
    710
    Likes Received:
    178
    Great you figured it out and posted the answer, it may help someone else in the same situation.
     
Loading...
Similar Threads - Image Transmission Signal Forum Date
No image transmission signal Phantom 4 Pro Help Jul 17, 2017
no image transmission signal Pro/Adv Discussion Jul 17, 2017
No image transmission signal Pro/Adv Discussion Jul 15, 2017
Standard Transmission signal No Image Transmission Phantom 3 Help Jul 8, 2017
"No Image Transmission Signal" ... a temporary blindness inflicted by God's? Pro/Adv Discussion Jul 7, 2017